Re: [PATCH] imap-send: increase command size limit
- From
René Scharfe <l.s.r@web.de>
- Date
- Apr 16, 2024, 15:31 UTC
- Message-ID
- <5d35dd4a-3569-4292-a736-45cfd0442f24@web.de>
- In-Reply-To
- <20240415184552.GA1709228@coredump.intra.peff.net>
Am 15.04.24 um 20:45 schrieb Jeff King:
Show 25 quoted lines
> On Mon, Apr 15, 2024 at 11:38:28AM -0700, Junio C Hamano wrote: > >>> I'm curious, is there a particular problem that you (or someone else) >>> ran into that caused you to make this change? I agree it seems prudent >>> in general, but if there's a particular real-world broken case that this >>> hits (e.g., mailbox names in a given language), I think the commit >>> message would be a great place to mention this real-world impact, which >>> would lend support to your argument that this is a valuable change to >>> make. >> >> I personally am not curious about real-world problem in this case, >> but I won't stop you asking ;-) >> >> I view this more about code simplification. We no longer need a >> custom nfvasprintf() helper nobody else cares about, leaving the >> resulting code easier to read. >> >> Will queue but will wait for a day or two to see if René wants to >> add clarification to the proposed commit log message before merging >> it to 'next'. > > Yeah, as the suggested-by person, I can affirm that this is not > something I saw in real life. I agree the primary motivation is the code > simplification, and dropping a pointless limit is the bonus. I'd > probably have written it in that style, but I'm OK either way.
Right, it's just intended as a code cleanup. I mention the limits only because lifting them is a change of behavior. Though you can now use passwords and folder names longer than 1000 characters, I don't expect that to catch on.
René