Re: [PATCH v1 3/3] convert: add filter.<driver>.useProtocol option
- From
Jakub Narębski <jnareb@gmail.com>
- Date
- Jul 24, 2016, 21:30 UTC
- Message-ID
- <5795337A.1040701@gmail.com>
- In-Reply-To
- <579521A1.4070501@gmail.com>
W dniu 2016-07-24 o 22:14, Jakub Narębski pisze:
> W dniu 2016-07-24 o 20:36, Lars Schneider pisze:
Show 9 quoted lines
>> I agree that the name is not ideal. "UseProtocol" as it is would be a boolean.
>> I thought about "persistent" but this name wouldn't convey the scope of the
>> persistency ("persistent for one Git operation" vs. "persistent for many Git
>> operations"). What do you think about the protocol as int version idea
>> described in $gmane/300155 ?
>
> You mean the `protocol` as a config variable name (fully name being
> `filter.<driver>.protocol`), being integer-valued, isn't it? Wouldn't
> `protocolVersion` be a more explicit?Just throwing out further ideas:
Perhaps make `persistent` string-valued variable, with the only value supported for now, namely "per-process" / "operation"?
Perhaps require for `pidfile` to be present for it to be daemon, that is persist for possibly many Git operations. Or allow "daemon" or "server" value for `persistent`, then?
-- Jakub Narębski