git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v6 02/39] api-lockfile: revise and expand the documentation

From
Michael Haggerty <mhagger@alum.mit.edu>
Date
Oct 1, 2014, 07:37 UTC
Message-ID
<542BAF33.9090406@alum.mit.edu>
In-Reply-To
<xmqqsij9rose.fsf@gitster.dls.corp.google.com>
On 09/30/2014 07:39 PM, Junio C Hamano wrote:
Show 24 quoted lines
> Michael Haggerty <mhagger@alum.mit.edu> writes:
> 
>> I was being repetitive because I didn't want the docs to depend on the
>> user remembering what the "bss" section is (which, technically, is also
>> not part of the C standard). I think a better way would be to just not
>> mention "bss section" at all and reword the rest. Maybe something like
>>
>>   The caller:
>>
>>   * Allocates a variable `struct lock_file lock`, initialized to zeros.
>>     Because the `lock_file` structure is used in an `atexit(3)` handler,
>>     its storage has to remain valid throughout the life of the program;
>>     e.g., it should be a static variable or space allocated on the heap.
>>
>> Better?
> 
> Somewhat.  I like that you droped "BSS", though.
> 
> 	Allocates a 'struct lock_file' either as a static variable
> 	or on the heap, initialized to zeros.  Once you use the
> 	structure to call hold_lock_file_* family of functions, it
> 	belongs to the lockfile subsystem and its storage must
> 	remain valid throughout the life of the program (i.e. you
> 	cannot use an on-stack variable to hold this structure).
OK, I'll use that.
Show 40 quoted lines
>>> It feels a bit conflicting between "must not be freed or ALTERED"
>>> and "it may be REUSED".  Drop "or altered" to reduce confusion?  And
>>> this repeats the third sentence I suggested to remove from the first
>>> paragraph (above 'see below' refers here).
>>
>> The purpose of "or altered" is to make sure that users don't imagine
>> that they should memset() the structure to zeros or something before
>> reusing it (especially since the "caller" instructions earlier say that
>> the object should be "initialized to zeros").
>>
>> Would it help if I change
>>
>>     s/altered/altered by the caller/
>>
>> ?
> 
> The fundamental rule is that callers outside the lockfile system must
> not touch individual members of "struct lock_file" that is "live".
> They must not free, they must not alter, they must not do anything
> other than calling the lockfile API functions.
> 
> While it is natural that the readers would understand such a rule
> must be followed for a lockfile that is in either the initialized,
> locked, closed-but-not-committed state, I agree that it is not just
> possible but likely that people misunderstand and think that once a
> lockfile is committed or rolled back it no longer has to follow that
> rule.  We would want to make sure readers do not fall into such a
> misunderstanding.
> 
> I dunno.  Your "if you memset it to NULs, you will break the linked
> list of the lock and the whole lockfile system and the element
> cannot even be reused." may be the most important thing you may have
> wanted to say, but it is not conveyed by that change at all, at
> least to me.
> 
> A small voice in the back of my skull keeps telling me that a rule
> that is hard to document and explain is a rule that does not make
> sense.  Is it possible to allow commit and rollback to safely remove
> the structure from the atexit(3) list (aka "no longer owned by the
> lockfile subsystem")?

Certainly it is possible. One would probably make lock_file an opaque data structure, always allocated on the heap within the lockfile subsystem, and maybe with a free list to reduce memory allocations.

But it would be a lot of work and I don't see a commensurate payoff. There are not *that* many callers of the lockfile API.

Show 29 quoted lines
>>> Is it allowed to tell the name of this lock_file to other people and
>>> let them read from it?  The answer is yes but it is not obvious from
>>> this description.
>>>
>>> Also mention how the above interact with reopen_lock_file() here?
>>
>> I'll take a stab at it, though TBH I haven't really studied the use case
>> for reopen_lock_file(). You might be better able to provide insight into
>> this topic.
> 
> You would want to be able to do this:
> 
>  - hold a lock on a file (say, the index);
> 
>  - update it in preparation to commit it;
> 
>  - write it out and make sure the contents is on the disk platter,
>    in preparation to call another program and allow it (and nobody
>    else) to inspect the contents you wrote, while still holding the
>    lock yourself.  In our set of API functions, close_lock_file is
>    what lets us do this.
> 
>  - further update it, write it out and commit.  We need to read it
>    first, open(2) it to write, write(2), and commit_lock_file().
> 
> The set of API functions you described in the document, there is no
> way to say "I already have a lock on that file, just let me open(2)
> for writing because I have further updates" and that is where reopen
> comes in.

Thanks for the clarification. My upcoming reroll will document reopen_lock_file().

Michael
-- 
Michael Haggerty
mhagger@alum.mit.edu
Previous: Junio C HamanoNext: Junio C Hamano
Message 7 of 55 in “Lockfile correctness and refactoring”
  1. 00/39 Lockfile correctness and refactoringMichael Haggerty, Sep 26, 2014
  2. 01/39 unable_to_lock_die(): rename function from unable_to_lock_index_die()Michael Haggerty, Sep 26, 2014
  3. 02/39 api-lockfile: revise and expand the documentationMichael Haggerty, Sep 26, 2014
  4. Junio C HamanoSep 26, 2014
  5. Michael HaggertySep 30, 2014
  6. Junio C HamanoSep 30, 2014
  7. Michael HaggertyOct 1, 2014
  8. Junio C HamanoSep 26, 2014
  9. Michael HaggertySep 30, 2014
  10. Jeff KingSep 30, 2014
  11. Junio C HamanoSep 30, 2014
  12. Michael HaggertyOct 1, 2014
  13. 03/39 close_lock_file(): exit (successfully) if file is already closedMichael Haggerty, Sep 26, 2014
  14. 04/39 rollback_lock_file(): do not clear filename redundantlyMichael Haggerty, Sep 26, 2014
  15. 05/39 rollback_lock_file(): exit early if lock is not activeMichael Haggerty, Sep 26, 2014
  16. 06/39 rollback_lock_file(): set fd to -1Michael Haggerty, Sep 26, 2014
  17. 07/39 lockfile: unlock file if lockfile permissions cannot be adjustedMichael Haggerty, Sep 26, 2014
  18. 08/39 hold_lock_file_for_append(): release lock on errorsMichael Haggerty, Sep 26, 2014
  19. 09/39 lock_file(): always initialize and register lock_file objectMichael Haggerty, Sep 26, 2014
  20. 10/39 lockfile.c: document the various states of lock_file objectsMichael Haggerty, Sep 26, 2014
  21. 11/39 cache.h: define constants LOCK_SUFFIX and LOCK_SUFFIX_LENMichael Haggerty, Sep 26, 2014
  22. 12/39 delete_ref_loose(): don't muck around in the lock_file's filenameMichael Haggerty, Sep 26, 2014
  23. 13/39 prepare_index(): declare return value to be (const char *)Michael Haggerty, Sep 26, 2014
  24. 14/39 write_packed_entry_fn(): convert cb_data into a (const int *)Michael Haggerty, Sep 26, 2014
  25. 15/39 lock_file(): exit early if lockfile cannot be openedMichael Haggerty, Sep 26, 2014
  26. 16/39 remove_lock_file(): call rollback_lock_file()Michael Haggerty, Sep 26, 2014
  27. 17/39 commit_lock_file(): inline temporary variableMichael Haggerty, Sep 26, 2014
  28. 18/39 commit_lock_file(): die() if called for unlocked lockfile objectMichael Haggerty, Sep 26, 2014
  29. 19/39 close_lock_file(): if close fails, roll backMichael Haggerty, Sep 26, 2014
  30. 20/39 commit_lock_file(): rollback lock file on failure to renameMichael Haggerty, Sep 26, 2014
  31. 21/39 api-lockfile: document edge casesMichael Haggerty, Sep 26, 2014
  32. 22/39 dump_marks(): remove a redundant call to rollback_lock_file()Michael Haggerty, Sep 26, 2014
  33. 23/39 git_config_set_multivar_in_file(): avoid call to rollback_lock_file()Michael Haggerty, Sep 26, 2014
  34. 24/39 lockfile: avoid transitory invalid statesMichael Haggerty, Sep 26, 2014
  35. 25/39 struct lock_file: declare some fields volatileMichael Haggerty, Sep 26, 2014
  36. 26/39 try_merge_strategy(): remove redundant lock_file allocationMichael Haggerty, Sep 26, 2014
  37. 27/39 try_merge_strategy(): use a statically-allocated lock_file objectMichael Haggerty, Sep 26, 2014
  38. Junio C HamanoSep 26, 2014
  39. Michael HaggertySep 30, 2014
  40. Junio C HamanoSep 30, 2014
  41. 28/39 commit_lock_file(): use a strbuf to manage temporary spaceMichael Haggerty, Sep 26, 2014
  42. 29/39 Change lock_file::filename into a strbufMichael Haggerty, Sep 26, 2014
  43. 30/39 resolve_symlink(): use a strbuf for internal scratch spaceMichael Haggerty, Sep 26, 2014
  44. 31/39 resolve_symlink(): take a strbuf parameterMichael Haggerty, Sep 26, 2014
  45. 32/39 trim_last_path_component(): replace last_path_elm()Michael Haggerty, Sep 26, 2014
  46. 33/39 Extract a function commit_lock_file_to()Michael Haggerty, Sep 26, 2014
  47. 34/39 Rename LOCK_NODEREF to LOCK_NO_DEREFMichael Haggerty, Sep 26, 2014
  48. 35/39 lockfile.c: rename static functionsMichael Haggerty, Sep 26, 2014
  49. 36/39 get_locked_file_path(): new functionMichael Haggerty, Sep 26, 2014
  50. 37/39 hold_lock_file_for_append(): restore errno before returningMichael Haggerty, Sep 26, 2014
  51. 38/39 Move read_index() definition to read-cache.cMichael Haggerty, Sep 26, 2014
  52. 39/39 lockfile.h: extract new header file for the functions in lockfile.cMichael Haggerty, Sep 26, 2014
  53. Junio C HamanoSep 26, 2014
  54. Michael HaggertySep 30, 2014
  55. Junio C HamanoSep 26, 2014

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.