Re: [PATCH 3/3] branch: rename orphan branches in any worktree
- From
Rubén Justo <rjusto@gmail.com>
- Date
- Jan 19, 2023, 23:34 UTC
- Message-ID
- <527f7315-be7b-7ec0-04fc-d07da7d4fefa@gmail.com>
- In-Reply-To
- <xmqqedrq1a7h.fsf@gitster.g>
On 19-ene-2023 13:33:06, Junio C Hamano wrote:
Show 11 quoted lines
> Rubén Justo <rjusto@gmail.com> writes: > > > + if (!copy && !(ishead > 1) && > > Logically it might be necessary to be able to extend "is that branch > what we have checked out, yes or no?" bool into something else that > can be something other than 0 or 1, but as soon as you did so, > "is_head" is no longer a Boolean "is it a HEAD, yes or no?". > > Now what does that value really _mean_? Please rename the variable > and helper function appropriately to make it clear what is going on.
The idea is that an unborn branch needs to be a HEAD, so (head > 1) codifies that information.
As I said in another reply in this thread, I'm going to reroll. I hope to make it clearer then.
Thank you.