Re: [PATCH v3 1/5] pull: rename pull.rename to pull.mode
- From
- Richard Hansen <rhansen@bbn.com>
- Date
- Oct 12, 2013, 00:32 UTC
- Message-ID
- <525898B9.5020904@bbn.com>
- In-Reply-To
- <52589027a4851_5dc4c2be742754f@nysa.mail>
On 2013-10-11 19:56, Felipe Contreras wrote:
Show 24 quoted lines
> Matthieu Moy wrote: >> Felipe Contreras <felipe.contreras@gmail.com> writes: >> >>> On Mon, Sep 9, 2013 at 9:21 PM, Jeff King <peff@peff.net> wrote: >>>> On Mon, Sep 09, 2013 at 05:49:36PM -0500, Felipe Contreras wrote: >>>> >>>>>> These deprecation warning messages should be written to stderr, and >>>>>> should probably be prefixed with "WARNING: ". >>>>> >>>>> Is there any deprecation warning that works this way? >>>> >>>> The ones in C code typically use warning(), which will prefix with >>>> "warning:" and write to stderr. They do not use all-caps, though. >>>> >>>> Try "git log --grep=deprecate -Swarning" for some examples. >>> >>> I'm asking about the ones in shell, because this is a shell script. >> >> No user cares whether "git pull" is written in shell. shell Vs C is an >> implementation detail, stdout Vs stderr is user-visible. > > You are free to go ahead and implement 'warning ()' in git-sh-setup.sh, in the > meantime no shell script does that, and that's no reason to reject this patch > series.
Sure, but is is a reason to reroll the patch series. Maybe it's not a strong enough reason on its own to reroll, but if you're going to reroll anyway, this should be fixed.
-Richard