Re: [PATCH v3 1/5] pull: rename pull.rename to pull.mode
- From
Felipe Contreras <felipe.contreras@gmail.com>
- Date
- Oct 11, 2013, 23:56 UTC
- Message-ID
- <52589027a4851_5dc4c2be742754f@nysa.mail>
- In-Reply-To
- <vpqmwnljdmn.fsf@anie.imag.fr>
Matthieu Moy wrote:
Show 19 quoted lines
> Felipe Contreras <felipe.contreras@gmail.com> writes: > > > On Mon, Sep 9, 2013 at 9:21 PM, Jeff King <peff@peff.net> wrote: > >> On Mon, Sep 09, 2013 at 05:49:36PM -0500, Felipe Contreras wrote: > >> > >>> > These deprecation warning messages should be written to stderr, and > >>> > should probably be prefixed with "WARNING: ". > >>> > >>> Is there any deprecation warning that works this way? > >> > >> The ones in C code typically use warning(), which will prefix with > >> "warning:" and write to stderr. They do not use all-caps, though. > >> > >> Try "git log --grep=deprecate -Swarning" for some examples. > > > > I'm asking about the ones in shell, because this is a shell script. > > No user cares whether "git pull" is written in shell. shell Vs C is an > implementation detail, stdout Vs stderr is user-visible.
You are free to go ahead and implement 'warning ()' in git-sh-setup.sh, in the meantime no shell script does that, and that's no reason to reject this patch series.
-- Felipe Contreras