Re: [PATCH] Add the GIT_SENTINEL macro
- From
Ramsay Jones <ramsay@ramsay1.demon.co.uk>
- Date
- Jul 20, 2013, 19:13 UTC
- Message-ID
- <51EAE146.2070309@ramsay1.demon.co.uk>
- In-Reply-To
- <7vr4evz0oc.fsf@alter.siamese.dyndns.org>
Junio C Hamano wrote:
Show 23 quoted lines
> Ramsay Jones <ramsay@ramsay1.demon.co.uk> writes: > >> The sentinel function attribute is not understood by versions of >> the gcc compiler prior to v4.0. At present, for earlier versions >> of gcc, the build issues 108 warnings related to the unknown >> attribute. In order to suppress the warnings, we conditionally >> define the GIT_SENTINEL macro to provide the sentinel attribute >> for gcc v4.0 and newer. >> >> Signed-off-by: Ramsay Jones <ramsay@ramsay1.demon.co.uk> >> --- >> >> This was built on the next branch > > It seems to apply well on the tip of jk/gcc-function-attributes. > > > - This macro is not about "git" at all, so I'll edit the patch to > call it GCC_ATTR_SENTINEL before applying. > > - Also I'll drop the (0) at the end. > > Thanks.
Yes, GCC_ATTR_SENTINEL is a better name, but I like LAST_ARG_MUST_BE_NULL even more! The final commit 9fe3edc4 ("Add the LAST_ARG_MUST_BE_NULL macro", 18-07-2013) is much better than my patch and works beautifully.
Thanks Junio, Jeff and Jonathan!
ATB, Ramsay Jones