git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 12/13] Documentation/Makefile: update git guide links

From
Philip Oakley <philipoakley@iee.org>
Date
Feb 26, 2013, 20:24 UTC
Message-ID
<512D1A0D.7020203@iee.org>
In-Reply-To
<7va9qsndnn.fsf@alter.siamese.dyndns.org>
On 26/02/13 00:04, Junio C Hamano wrote:
Show 16 quoted lines
> Philip Oakley <philipoakley@iee.org> writes:
>
>> On 25/02/13 05:29, Junio C Hamano wrote:
>> ...
>>> In other words, can't you change the side that launches the document
>>> viewer so that we do not have to rename anything in the first place?
>>
>> The current help code will only show either 'git-<cmd>' man pages, or
>> git<guide>' pages so the current everyday and user-manual pages aren't
>> served by the existing help code.
>
> That is exactly what I meant by "the side that launches the document
> viewer".  We obviously would not want to type
>
> 	$ git help gituser-manual
>          $ git help giteveryday
Neither do I...
>
> I was wondering if you can keep document names as-is, register these
> names without "git" prefix (i.e. "user-manual.html")

I don't register them at all. I'm simply gathering a list of common guides in the array so that I can show that list as a 'usage' list, in exactly the same manner as the common commands list is used when 'git help' [ no options] is typed.

Show 5 quoted lines
>   to the list of
> guide documents you are generating and compiling into the binary,
> and let the user ask:
>
> 	$ git help everyday

This is the existing way. 'git help tutorial' will display the gittutorial.txt man page - Note the git prefix is required by the code.

It is interesting to note that 'git help k' and 'git help gitk' produce the same response, while gitk can't be a common-command because it doesn't have a dashed form so isn't picked up by the script ;-)

Show 9 quoted lines
>
> which you would turn into "browser %s/%s.html" % (GIT_HTML_PATH, 'everyday'),
> after checking "everyday" is one of the guides that are available to us.
>
> If some guides are already named with git prefix, you can keep them
> in the compiled-in list with that name.  We do not have to worry
> about redirects and people's bookmarks if we can avoid renaming
> existing pages, so "because grabbing everything with git* glob was
> easier to write the generate-guidelist script" is a false economy.

I was hoping to avoid more special casing of special files for special purposes..

> That is the single place we can afford to spend extra effort to make
> the end result easier to use by the users, no?
It could be done.
>
> Or am I misreading the series completely?
Yes, I think so (in terms of my starting point and approach).

I was using the existing common-commands approach _just_ to display a 'usage' string of common guides. so that new users would be informed of their presence, and then they would use the existing command 'git help <guide>' to read about it (see also patch 2/13).

It was just unfortunate that the user-manual and everyday didn't fit the existing naming pattern causing the writing of patch 8 & 9 et seq to sort the renames to fit the pattern (just like git-remote-helpers)

Also, I think it's the user-manual, one of the files doesn't fit the 'man page' style required by the MAN7 list in Documentation/Makefile, so that's another potential complication I need to bottom out - most likely keep it 'as is' in the Makefile and check that the Help command will display it properly if done that way.

Philip
Previous: Junio C HamanoNext: Philip Oakley
Message 34 of 37 in “Git help option to list user guides”
  1. 00/13 Git help option to list user guidesPhilip Oakley, Feb 23, 2013
  2. 01/13 Use 'Git' in help messagesPhilip Oakley, Feb 23, 2013
  3. David AguilarFeb 23, 2013
  4. Philip OakleyFeb 23, 2013
  5. Junio C HamanoFeb 24, 2013
  6. Philip OakleyFeb 24, 2013
  7. David AguilarFeb 24, 2013
  8. 02/13 Show 'git help <guide>' usage, with examplesPhilip Oakley, Feb 23, 2013
  9. W. Trevor KingFeb 24, 2013
  10. Philip OakleyFeb 24, 2013
  11. 03/13 Help.c use OPT_COUNTUPPhilip Oakley, Feb 23, 2013
  12. 04/13 Help.c add --guide optionPhilip Oakley, Feb 23, 2013
  13. 05/13 Help.c: add list_common_guides_help() functionPhilip Oakley, Feb 23, 2013
  14. Junio C HamanoFeb 24, 2013
  15. Philip OakleyFeb 24, 2013
  16. Junio C HamanoFeb 25, 2013
  17. Philip OakleyFeb 25, 2013
  18. Junio C HamanoFeb 25, 2013
  19. 06/13 Add guide-list.txt and extraction shellPhilip Oakley, Feb 23, 2013
  20. W. Trevor KingFeb 24, 2013
  21. Philip OakleyFeb 24, 2013
  22. 07/13 Extend name string for longer namesPhilip Oakley, Feb 23, 2013
  23. 09/13 Rename everyday to giteverydayPhilip Oakley, Feb 23, 2013
  24. W. Trevor KingFeb 24, 2013
  25. Philip OakleyFeb 24, 2013
  26. 10/13 Update Git(1) links to guidesPhilip Oakley, Feb 23, 2013
  27. 11/13 Add missing guides to list and regeneratePhilip Oakley, Feb 23, 2013
  28. 12/13 Documentation/Makefile: update git guide linksPhilip Oakley, Feb 23, 2013
  29. W. Trevor KingFeb 24, 2013
  30. Philip OakleyFeb 24, 2013
  31. Junio C HamanoFeb 25, 2013
  32. Philip OakleyFeb 25, 2013
  33. Junio C HamanoFeb 26, 2013
  34. Philip OakleyFeb 26, 2013
  35. 13/13 Fixup! doc: giteveryday and user-manual man formatPhilip Oakley, Feb 23, 2013
  36. W. Trevor KingFeb 24, 2013
  37. Philip OakleyFeb 24, 2013

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.