git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v4 04/14] Add new simplified git-remote-testgit

From
Stefano Lattarini <stefano.lattarini@gmail.com>
Date
Nov 2, 2012, 16:03 UTC
Message-ID
<5093EEB4.3040402@gmail.com>
In-Reply-To
<CAMP44s0n_O-7j329WyTxsWgVbCV2mEAnPG-WQeWBFdmHdfOjnQ@mail.gmail.com>
On 11/02/2012 04:42 PM, Felipe Contreras wrote:
Show 37 quoted lines
> On Fri, Nov 2, 2012 at 2:55 PM, Stefano Lattarini
> <stefano.lattarini@gmail.com> wrote:
> 
>>> +#!/bin/bash
>>>
>> I think git can't assume the existence of bash unconditionally, neither
>> in its scripts, nor in its tests (the exception being the tests on
>> bash completion, of course).  This script probably need to be re-written
>> to be a valid POSIX shell script.
> 
> Well, this is a _reference_ script, and that is used only for testing
> purposes. The test itself can be like the bash completion tests, and
> simply be skipped.
> 
> The reason I chose bash is because associative arrays, which you see
> in a later patch.
> 
>> It almost is, anyway, apart from the nits below ...
>>
>>> +# Copyright (c) 2012 Felipe Contreras
>>> +
>>> +alias="$1"
>>>
>> Just FYI: the double quoting here (and in several variable assignments
>> below) is redundant.  You can portably write it as:
>>
>>     alias=$1
>>
>> and still be safe in the face of spaces and metacharacters in $1.
>> I'm not sure whether the Git coding guidelines suggest the use of
>> quoting in this situation though; if this is the case, feel free
>> to disregard my observation.
> 
> What happens when you call this with:
> 
>  ./script "alias with spaces"
>
'$alias' will correctly expand to "alias with spaces".  Try out:
  $ sh -c 'alias=$1; echo "$alias"' dummy '1   2*3'
  1   2*3

This works consistently with every known shell (even non-POSIX relics like Solaris /bin/sh).

Show 22 quoted lines
>>> +url="$2"
>>> +
>>> +# huh?
>>> +url="${url#file://}"
>>> +
>>> +dir="$GIT_DIR/testgit/$alias"
>>> +prefix="refs/testgit/$alias"
>>> +refspec="refs/heads/*:${prefix}/heads/*"
>>> +
>>> +gitmarks="$dir/git.marks"
>>> +testgitmarks="$dir/testgit.marks"
>>> +
>>> +export GIT_DIR="$url/.git"
>>> +
>> I believe this should be rewritten as:
>>
>>   GIT_DIR="$url/.git"; export GIT_DIR
>>
>> in order to be portable to all the POSIX shells targeted by Git.
> 
> _If_ we want this as POSIX, yeah.
>
Why don't we?  Why add an extra requirement for a test that
 1. can be easily written in POSIX shell, and
 2. tests a feature that doesn't require bash to work (unless
    I'm sorely mistaken, that is)?

Honest question. But of course, if the Git active contributors deem the extra requirement (which is not an invasive one, given how often bash is installed even on non-Linux systems) acceptable in order to have the test case simpler and clearer, feel free to disregard all my observations in this thread.

Show 24 quoted lines
>>> +mkdir -p "$dir"
>>> +
>>> +test -e "$gitmarks" || echo -n > "$gitmarks"
>>> +test -e "$testgitmarks" || echo -n > "$testgitmarks"
>>> +
>> The '-n' option to echo is not portable.  To create an empty
>> file, you can just use
>>
>>    : > file
>>
>> or
>>
>>    true > file
> 
> All right, thanks.
> 
>>> +while read line; do
>>> +    case "$line" in
>>>
>> Useless double quoting (my previous observation about Git coding
>> guidelines applies here as well, of course).
> 
> What if line has multiple spaces?
>
Still no problem, as in the case of the 'alias=$1' assignment before:
  $ sh -c 'case $1 in *x"  "x*) echo ok;; *) exit 1;; esac' dummy 'x  x'
  ok
> To me it makes sense to quote it.
>

Surely it doesn't cause any problem to "over-quote" in this case; it's better than risking to under-quote in other. I just pointed out that the quoting it's not really necessary, in case you weren't aware of that.

Show 13 quoted lines
>>> +        echo "feature import-marks=$gitmarks"
>>> +        echo "feature export-marks=$gitmarks"
>>> +        git fast-export --use-done-feature --{import,export}-marks="$testgitmarks" $refs | \
>>>
>> Better avoid the tricky {foo,bar} bashism:
>>
>>     git fast-export --use-done-feature \
>>                     --import-marks="$testgitmarks" \
>>                     --export-marks="$testgitmarks" \
>>                     $refs | \
> 
> If that's what we want, yeah.
>

Honestly, I find my longer-and-more-explicit version clearer, even if you can assume bash for your script. But that's a matter of personal preference (sorry for not stating that right away), so feel free to ignore it if you decide to keep the bash requirement in the end.

Regards,
  Stefano
Previous: Felipe ContrerasNext: Felipe Contreras
Message 9 of 26 in “fast-export and remote-testgit improvements”
  1. 00/14 fast-export and remote-testgit improvementsFelipe Contreras, Nov 2, 2012
  2. 01/14 fast-export: avoid importing blob marksFelipe Contreras, Nov 2, 2012
  3. 02/14 remote-testgit: fix direction of marksFelipe Contreras, Nov 2, 2012
  4. 03/14 Rename git-remote-testgit to git-remote-testpyFelipe Contreras, Nov 2, 2012
  5. 04/14 Add new simplified git-remote-testgitFelipe Contreras, Nov 2, 2012
  6. Stefano LattariniNov 2, 2012
  7. Jeff KingNov 2, 2012
  8. Felipe ContrerasNov 2, 2012
  9. Stefano LattariniNov 2, 2012
  10. Felipe ContrerasNov 2, 2012
  11. 05/14 remote-testgit: get rid of non-local functionalityFelipe Contreras, Nov 2, 2012
  12. 06/14 remote-testgit: remove irrelevant testFelipe Contreras, Nov 2, 2012
  13. 07/14 remote-testgit: cleanup testsFelipe Contreras, Nov 2, 2012
  14. 08/14 remote-testgit: exercise more featuresFelipe Contreras, Nov 2, 2012
  15. 09/14 remote-testgit: report success after an importFelipe Contreras, Nov 2, 2012
  16. Stefano LattariniNov 2, 2012
  17. Felipe ContrerasNov 2, 2012
  18. Stefano LattariniNov 2, 2012
  19. Felipe ContrerasNov 2, 2012
  20. Stefano LattariniNov 2, 2012
  21. Jeff KingNov 2, 2012
  22. 10/14 remote-testgit: make clear the 'done' featureFelipe Contreras, Nov 2, 2012
  23. 11/14 fast-export: trivial cleanupFelipe Contreras, Nov 2, 2012
  24. 12/14 fast-export: fix comparison in testsFelipe Contreras, Nov 2, 2012
  25. 13/14 fast-export: make sure updated refs get updatedFelipe Contreras, Nov 2, 2012
  26. 14/14 fast-export: don't handle uninteresting refsFelipe Contreras, Nov 2, 2012

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.