git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v2 0/7] Improved infrastructure for refname normalization

From
Michael Haggerty <mhagger@alum.mit.edu>
Date
Sep 12, 2011, 15:11 UTC
Message-ID
<4E6E2122.8000201@alum.mit.edu>
In-Reply-To
<7vehzmbd0o.fsf@alter.siamese.dyndns.org>
On 09/12/2011 06:28 AM, Junio C Hamano wrote:
Show 10 quoted lines
> Michael Haggerty <mhagger@alum.mit.edu> writes:
> There were a few minor things that looked worth mentioning while
> reviewing, though.
> 
>  - (style) You seem to be fond of pre-increment a lot, but in general our
>    codebase prefers post-increment especially when the end result does not
>    make any difference, e.g.
> 
> 	for (i = 1; ...; ++i) {
>         	...
OK, changed.
>  - (series structure) It might make the series progress easier to follow
>    if you introduced check_ref_format_unsafe() in the same commit where
>    you change check_ref_format() to take flags parameter.

OK. I'll take the opportunity to rename the functions to check_refname_format*(), to make it more obvious that they only concern themselves with the refnames and not the references themselves.

I discovered a bug in my code for handling refnames without normalization; I will also fix that in v3.

OTOH I am again having serious doubts that trying to support unnormalized refnames is a good idea. I will write more when I have time to argue my case.

Michael
-- 
Michael Haggerty
mhagger@alum.mit.edu
http://softwareswirl.blogspot.com/
Previous: Junio C HamanoNext: Junio C Hamano
Message 10 of 13 in “Improved infrastructure for refname normalization”
  1. 0/7 Improved infrastructure for refname normalizationMichael Haggerty, Sep 10, 2011
  2. 1/7 t1402: add some more testsMichael Haggerty, Sep 10, 2011
  3. 2/7 Change bad_ref_char() to return a boolean valueMichael Haggerty, Sep 10, 2011
  4. 3/7 git check-ref-format: add options --allow-onelevel and --refspec-patternMichael Haggerty, Sep 10, 2011
  5. 4/7 Change check_ref_format() to take a flags argumentMichael Haggerty, Sep 10, 2011
  6. 5/7 Add a library function normalize_refname()Michael Haggerty, Sep 10, 2011
  7. 6/7 Do not allow ".lock" at the end of any refname componentMichael Haggerty, Sep 10, 2011
  8. 7/7 Add tools to avoid the use of unnormalized refnames.Michael Haggerty, Sep 10, 2011
  9. Junio C HamanoSep 12, 2011
  10. Michael HaggertySep 12, 2011
  11. Junio C HamanoSep 12, 2011
  12. Michael HaggertySep 13, 2011
  13. Junio C HamanoSep 13, 2011

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.