Re: [PATCH 2] count-objects: add human-readable size option
- From
Marcus Griep <marcus@griep.us>
- Date
- Aug 14, 2008, 16:26 UTC
- Message-ID
- <48A45CC9.5040708@griep.us>
- In-Reply-To
- <20080814151451.GA10544@machine.or.cz>
Petr Baudis wrote:
> Are you aware of progress.c:throughput_string()? It would make sense to > use the same code in both instances.
I was not. After reviewing it, it is limited to its purposes (who's got transfer speeds in TiB/s?), but consolidating the human-readable-ness is a good idea.
> I'd prefer you to keep using binary units instead of the ambiguous > prefixes, since we should keep our output consistent and I believe they > usually end up to be the least confusing choice. (Otherwise, don't you > want to use "bkM" instead of "BKM"? I never really know.)
In general, "b" would be supplied as a part of the suffix, so that is no longer in the prefix list. The distinction comes with kilo vs. kibi. In an earlier email reply, I mentioned a flag to denote SI versus binary periods. In common nomenclature, Kilo (1000) is designated 'k', while Kibi (1024) is designated 'K' (the 'i' after the 'K' is supplied by the suffix if desired). Thus, if the user wants binary, they'll get the capital 'K', and if they want SI, they'll get the lowercase 'k'.
Sound reasonable?
-- Marcus Griep GPG Key ID: 0x5E968152 —— http://www.boohaunt.net את.ψο´