Re: [PATCH] topgit tg push feature
2009/5/7 Uwe Kleine-König <u.kleine-koenig@pengutronix.de>:
Show 28 quoted lines
> Hi Marc, hi Bert,
>> > + # if so desired omit non tgish deps
>> > + [ -z "$tgish_deps_only" ] || [ -n "$_dep_is_tgish" ] || return 0
> I've always problems to understand these constructs. Are these any
> better than
>
> if test ...; then
> return 0
> fi
>
> ? And I think it's more readable to use
>
> tgish_deps_only=false
>
> ...
> --tgish-only)
> tgish_deps_only=true;;
>
> ...
>
> if $tgish_deps_only; then
>
> ...
>
> fi
>
> . (OK, I have to admit, that these constructs are used everywhere in
> topgit, but I'm not happy with these either.)
I also like the true/false style, its also useable with the current 'scheme':
$tgish_deps_only && ...