Re: [PATCH] topgit tg push feature
- From
- martin f krafft <madduck@madduck.net>
- Date
- May 11, 2009, 07:25 UTC
- Message-ID
- <20090511072507.GA24235@lapse.rw.madduck.net>
- In-Reply-To
- <20090511032813.GA15540@gmx.de>
also sprach Marc Weber <marco-oweber@gmx.de> [2009.05.11.0528 +0200]:
> >I also like the true/false style, its also useable with the current 'scheme': > > $tgish_deps_only && ... > great idea. true/false are sh builtins. adopted. I still prefer > [ foo -a bar ]; or [ foo -o bar ]; for readability.
The patch looks good, I am going to test it now, I hope.
Quick comment: -a and -o are not POSIX-compliant, use [ "$foo" ] || [ "$bar" ] instead.
-- martin | http://madduck.net/ | http://two.sentenc.es/ the early bird may get the worm, but the second mouse gets the cheese in the trap. spamtraps: madduck.bogus@madduck.net