Re: [PATCH 3/3] bundle-uri: remove GIT_TEST_BUNDLE_URI env variable
- From
Ævar Arnfjörð Bjarmason <avarab@gmail.com>
- Date
- Dec 19, 2022, 11:09 UTC
- Message-ID
- <221219.86len3zlqj.gmgdl@evledraar.gmail.com>
- In-Reply-To
- <aafee168fbae2a1887f53febc4abd15522b12bc2.1670866407.git.gitgitgadget@gmail.com>
On Mon, Dec 12 2022, Derrick Stolee via GitGitGadget wrote:
Show 6 quoted lines
> From: Derrick Stolee <derrickstolee@github.com> > > The GIT_TEST_BUNDLE_URI environment variable is used in the t573* suite > of tests that consume the bundle URIs advertised by the Git server. This > variable is equivalent to setting transfer.bundleURI=true, so we can do > that in these tests instead.
I think this is probably OK. I can't remember why I added both the env variable and the setting in what became 0ef961dda05 (bundle-uri client: add boolean transfer.bundleURI setting, 2022-12-05).
But I think this commit message really doesn't explain why it's OK to remove it. In general we do have GIT_TEST_* settings that duplicate config, e.g. GIT_TEST_PROTOCOL_VERSION.
We do so because we'd like the environment variable to override the setting, or the other way around (I think depending on the GIT_TEST_* variable it's either-or, it's a mess).
But in this case we'd never like to combine the two?
> The environment variable has a name that implies it would be useful > outside of these tests. It is not useful to set across all tests since > it would do very little without some setup on the server side. Remove > it.
This part I really don't get, why does its name imply that? We use GIT_TEST_* variables for this sort of thing, maybe it's not needed here, but what should it have been named? GIT_TEST_T57XX_* or something?
I named it like that for consistency with existing test variables, ...