git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH v2 10/13] push: remove redundant check

From
Felipe Contreras <felipe.contreras@gmail.com>
Date
May 31, 2021, 19:51 UTC
Message-ID
<20210531195124.218325-11-felipe.contreras@gmail.com>
In-Reply-To
<20210531195124.218325-1-felipe.contreras@gmail.com>

If fetch_remote is NULL (i.e. the branch remote is invalid), then it can't possibly be same as remote, which can't be NULL.

The check is redundant, and so is the extra variable.

Also, fix the Yoda condition: we want to check if remote is the same as the branch remote, not the other way around.

Signed-off-by: Felipe Contreras <felipe.contreras@gmail.com>
---
 builtin/push.c | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/builtin/push.c b/builtin/push.c
index b5e951bf59..aa22d6a8e5 100644
--- a/builtin/push.c
+++ b/builtin/push.c
@@ -204,8 +204,7 @@ static const char *get_upstream_ref(struct branch *branch, const char *remote_na
 
 static int is_same_remote(struct remote *remote)
 {
-	struct remote *fetch_remote = remote_get(NULL);
-	return (!fetch_remote || fetch_remote == remote);
+	return remote == remote_get(NULL);
 }
 
 static void setup_default_push_refspecs(struct remote *remote)
-- 
2.32.0.rc0
Previous: Felipe ContrerasNext: Junio C Hamano
Message 22 of 24 in “Unconvolutize push.default=simple”
  1. 0/7 Unconvolutize push.default=simpleFelipe Contreras, May 31, 2021
  2. 1/7 push: rename !triangular to same_remoteFelipe Contreras, May 31, 2021
  3. 2/7 push: hedge code of default=simpleFelipe Contreras, May 31, 2021
  4. 3/7 push: copy code to setup_push_simple()Felipe Contreras, May 31, 2021
  5. 4/7 push: reorganize setup_push_simple()Felipe Contreras, May 31, 2021
  6. 5/7 push: simplify setup_push_simple()Felipe Contreras, May 31, 2021
  7. 7/7 doc: push: explain default=simple correctlyFelipe Contreras, May 31, 2021
  8. 6/7 push: remove unused code in setup_push_upstream()Felipe Contreras, May 31, 2021
  9. 00/13 push: revamp push.defaultFelipe Contreras, May 31, 2021
  10. 01/13 push: create new get_upstream_ref() helperFelipe Contreras, May 31, 2021
  11. 02/13 push: return immediately in trivial switch caseFelipe Contreras, May 31, 2021
  12. 03/13 push: split switch casesFelipe Contreras, May 31, 2021
  13. 04/13 push: factor out null branch checkFelipe Contreras, May 31, 2021
  14. 05/13 push: only get the branch when neededFelipe Contreras, May 31, 2021
  15. 08/13 push: get rid of all the setup_push_* functionsFelipe Contreras, May 31, 2021
  16. 07/13 push: trivial simplificationsFelipe Contreras, May 31, 2021
  17. 09/13 push: factor out the typical caseFelipe Contreras, May 31, 2021
  18. 12/13 push: only check same_remote when neededFelipe Contreras, May 31, 2021
  19. 11/13 push: remove trivial functionFelipe Contreras, May 31, 2021
  20. 06/13 push: make setup_push_* return the dstFelipe Contreras, May 31, 2021
  21. 13/13 push: don't get a full remote objectFelipe Contreras, May 31, 2021
  22. 10/13 push: remove redundant checkFelipe Contreras, May 31, 2021
  23. Junio C HamanoJun 2, 2021
  24. Felipe ContrerasJun 2, 2021

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.