git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH v3 0/7] Unconvolutize push.default=simple

From
Felipe Contreras <felipe.contreras@gmail.com>
Date
May 31, 2021, 19:32 UTC
Message-ID
<20210531193237.216726-1-felipe.contreras@gmail.com>

Tired of jumping through hoops trying to understand what the "simple" mode does, I decided to reorganize it up for good so it's crystal clear.

There are no functional changes.

Basically the simple mode pushes the current branch with the same name on the remote.

Except... when there's no upstream branch configured with the same name.
Now the code and the documentation are clear.

The difference from v2 is that now triangular is renamed to same_remote in the very first patch. That way the rest of both series are easier to digest.

Unfortunately the first patch is a little noisy, and the same with the rangediff. That might be a small price to pay to make the rest easier.

The result of this series is in short this function:
static void setup_push_simple(struct remote *remote, struct branch *branch, int same_remote)
{
	if (!branch)
		die(_(message_detached_head_die), remote->name);
	if (same_remote) {
		if (!branch->merge_nr || !branch->merge || !branch->remote_name)
			die(_("The current branch %s has no upstream branch.\n"
			    "To push the current branch and set the remote as upstream, use\n"
			    "\n"
			    "    git push --set-upstream %s %s\n"),
			    branch->name,
			    remote->name,
			    branch->name);
		if (branch->merge_nr != 1)
			die(_("The current branch %s has multiple upstream branches, "
			    "refusing to push."), branch->name);
		/* Additional safety */
		if (strcmp(branch->refname, branch->merge[0]->src))
			die_push_simple(branch, remote);
	}
	refspec_appendf(&rs, "%s:%s", branch->refname, branch->refname);
}
Felipe Contreras (7):
  push: rename !triangular to same_remote
  push: hedge code of default=simple
  push: copy code to setup_push_simple()
  push: reorganize setup_push_simple()
  push: simplify setup_push_simple()
  push: remove unused code in setup_push_upstream()
  doc: push: explain default=simple correctly
 Documentation/config/push.txt | 13 +++++-----
 builtin/push.c                | 48 +++++++++++++++++++++++------------
 2 files changed, 38 insertions(+), 23 deletions(-)
Range-diff against v2:
1:  f1f42bda32 < -:  ---------- push: hedge code of default=simple
-:  ---------- > 1:  e8efe0d844 push: rename !triangular to same_remote
-:  ---------- > 2:  f84aa09a93 push: hedge code of default=simple
2:  bb6d810011 ! 3:  7d04af5b2c push: move code to setup_push_simple()
    @@ Metadata
     Author: Felipe Contreras <felipe.contreras@gmail.com>
     
      ## Commit message ##
    -    push: move code to setup_push_simple()
    +    push: copy code to setup_push_simple()
     
         In order to avoid doing unnecessary things and simplify it in further
    -    patches.
    +    patches. In particular moving the additional name safety out of
    +    setup_push_upstream() and into setup_push_simple() and thus making both
    +    more straightforward.
     
         The code is copied exactly as-is; no functional changes.
     
    @@ Commit message
      ## builtin/push.c ##
     @@ builtin/push.c: static void setup_push_current(struct remote *remote, struct branch *branch)
      
    - static void setup_push_simple(struct remote *remote, struct branch *branch, int triangular)
    + static void setup_push_simple(struct remote *remote, struct branch *branch, int same_remote)
      {
    --	if (triangular)
    +-	if (!same_remote)
     -		setup_push_current(remote, branch);
     -	else
    --		setup_push_upstream(remote, branch, triangular, 1);
    -+	if (triangular) {
    +-		setup_push_upstream(remote, branch, same_remote, 1);
    ++	if (!same_remote) {
     +		if (!branch)
     +			die(_(message_detached_head_die), remote->name);
     +		refspec_appendf(&rs, "%s:%s", branch->refname, branch->refname);
    @@ builtin/push.c: static void setup_push_current(struct remote *remote, struct bra
     +		if (branch->merge_nr != 1)
     +			die(_("The current branch %s has multiple upstream branches, "
     +			    "refusing to push."), branch->name);
    -+		if (triangular)
    ++		if (!same_remote)
     +			die(_("You are pushing to remote '%s', which is not the upstream of\n"
     +			      "your current branch '%s', without telling me what to push\n"
     +			      "to update which remote branch."),
    @@ builtin/push.c: static void setup_push_current(struct remote *remote, struct bra
     +	}
      }
      
    - static int is_workflow_triangular(struct remote *remote)
    + static int is_same_remote(struct remote *remote)
3:  d66a442fba ! 4:  5e0e09bc7a push: reorganize setup_push_simple()
    @@ Commit message
         push: reorganize setup_push_simple()
     
         Simply move the code around and remove dead code. In particular the
    -    'trivial' conditional is a no-op since that part of the code is the
    -    !trivial leg of the conditional beforehand.
    +    '!same_remote' conditional is a no-op since that part of the code is the
    +    same_remote leg of the conditional beforehand.
     
         No functional changes.
     
    @@ Commit message
      ## builtin/push.c ##
     @@ builtin/push.c: static void setup_push_current(struct remote *remote, struct branch *branch)
      
    - static void setup_push_simple(struct remote *remote, struct branch *branch, int triangular)
    + static void setup_push_simple(struct remote *remote, struct branch *branch, int same_remote)
      {
     +	const char *dst;
     +
     +	if (!branch)
     +		die(_(message_detached_head_die), remote->name);
     +
    - 	if (triangular) {
    + 	if (!same_remote) {
     -		if (!branch)
     -			die(_(message_detached_head_die), remote->name);
     -		refspec_appendf(&rs, "%s:%s", branch->refname, branch->refname);
    @@ builtin/push.c: static void setup_push_simple(struct remote *remote, struct bran
      		if (branch->merge_nr != 1)
      			die(_("The current branch %s has multiple upstream branches, "
      			    "refusing to push."), branch->name);
    --		if (triangular)
    +-		if (!same_remote)
     -			die(_("You are pushing to remote '%s', which is not the upstream of\n"
     -			      "your current branch '%s', without telling me what to push\n"
     -			      "to update which remote branch."),
    @@ builtin/push.c: static void setup_push_simple(struct remote *remote, struct bran
     +	refspec_appendf(&rs, "%s:%s", branch->refname, dst);
      }
      
    - static int is_workflow_triangular(struct remote *remote)
    + static int is_same_remote(struct remote *remote)
4:  eaae6a826a ! 5:  723d95b572 push: simplify setup_push_simple()
    @@ Metadata
      ## Commit message ##
         push: simplify setup_push_simple()
     
    -    There's a safety check to make sure branch->refname is not different
    +    There's a safety check to make sure branch->refname isn't different
         from branch->merge[0]->src, otherwise we die().
     
         Therefore we always push to branch->refname.
    @@ Commit message
      ## builtin/push.c ##
     @@ builtin/push.c: static void setup_push_current(struct remote *remote, struct branch *branch)
      
    - static void setup_push_simple(struct remote *remote, struct branch *branch, int triangular)
    + static void setup_push_simple(struct remote *remote, struct branch *branch, int same_remote)
      {
     -	const char *dst;
     -
      	if (!branch)
      		die(_(message_detached_head_die), remote->name);
      
    --	if (triangular) {
    +-	if (!same_remote) {
     -		dst = branch->refname;
     -	} else {
    -+	if (!triangular) {
    ++	if (same_remote) {
      		if (!branch->merge_nr || !branch->merge || !branch->remote_name)
      			die(_("The current branch %s has no upstream branch.\n"
      			    "To push the current branch and set the remote as upstream, use\n"
    @@ builtin/push.c: static void setup_push_simple(struct remote *remote, struct bran
     +	refspec_appendf(&rs, "%s:%s", branch->refname, branch->refname);
      }
      
    - static int is_workflow_triangular(struct remote *remote)
    + static int is_same_remote(struct remote *remote)
5:  8d9ae5e552 ! 6:  8ffaacd0db push: remove unused code in setup_push_upstream()
    @@ builtin/push.c: static const char message_detached_head_die[] =
      	   "    git push %s HEAD:<name-of-remote-branch>\n");
      
      static void setup_push_upstream(struct remote *remote, struct branch *branch,
    --				int triangular, int simple)
    -+				int triangular)
    +-				int same_remote, int simple)
    ++				int same_remote)
      {
      	if (!branch)
      		die(_(message_detached_head_die), remote->name);
    @@ builtin/push.c: static void setup_default_push_refspecs(struct remote *remote)
      		break;
      
      	case PUSH_DEFAULT_UPSTREAM:
    --		setup_push_upstream(remote, branch, triangular, 0);
    -+		setup_push_upstream(remote, branch, triangular);
    +-		setup_push_upstream(remote, branch, same_remote, 0);
    ++		setup_push_upstream(remote, branch, same_remote);
      		break;
      
      	case PUSH_DEFAULT_CURRENT:
6:  b35bdf14dc = 7:  3cc20c876f doc: push: explain default=simple correctly
-- 
2.32.0.rc0
Next: Felipe Contreras
Message 1 of 24 in “Unconvolutize push.default=simple”
  1. 0/7 Unconvolutize push.default=simpleFelipe Contreras, May 31, 2021
  2. 1/7 push: rename !triangular to same_remoteFelipe Contreras, May 31, 2021
  3. 2/7 push: hedge code of default=simpleFelipe Contreras, May 31, 2021
  4. 3/7 push: copy code to setup_push_simple()Felipe Contreras, May 31, 2021
  5. 4/7 push: reorganize setup_push_simple()Felipe Contreras, May 31, 2021
  6. 5/7 push: simplify setup_push_simple()Felipe Contreras, May 31, 2021
  7. 7/7 doc: push: explain default=simple correctlyFelipe Contreras, May 31, 2021
  8. 6/7 push: remove unused code in setup_push_upstream()Felipe Contreras, May 31, 2021
  9. 00/13 push: revamp push.defaultFelipe Contreras, May 31, 2021
  10. 01/13 push: create new get_upstream_ref() helperFelipe Contreras, May 31, 2021
  11. 02/13 push: return immediately in trivial switch caseFelipe Contreras, May 31, 2021
  12. 03/13 push: split switch casesFelipe Contreras, May 31, 2021
  13. 04/13 push: factor out null branch checkFelipe Contreras, May 31, 2021
  14. 05/13 push: only get the branch when neededFelipe Contreras, May 31, 2021
  15. 08/13 push: get rid of all the setup_push_* functionsFelipe Contreras, May 31, 2021
  16. 07/13 push: trivial simplificationsFelipe Contreras, May 31, 2021
  17. 09/13 push: factor out the typical caseFelipe Contreras, May 31, 2021
  18. 12/13 push: only check same_remote when neededFelipe Contreras, May 31, 2021
  19. 11/13 push: remove trivial functionFelipe Contreras, May 31, 2021
  20. 06/13 push: make setup_push_* return the dstFelipe Contreras, May 31, 2021
  21. 13/13 push: don't get a full remote objectFelipe Contreras, May 31, 2021
  22. 10/13 push: remove redundant checkFelipe Contreras, May 31, 2021
  23. Junio C HamanoJun 2, 2021
  24. Felipe ContrerasJun 2, 2021

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.