Re: [PATCH 3/7] t7415: rename to expand scope
- From
Jeff King <peff@peff.net>
- Date
- Oct 5, 2020, 08:24 UTC
- Message-ID
- <20201005082448.GB2862927@coredump.intra.peff.net>
- In-Reply-To
- <20201005075020.GF1166820@google.com>
On Mon, Oct 05, 2020 at 12:50:20AM -0700, Jonathan Nieder wrote:
Show 7 quoted lines
> > ...5-submodule-names.sh => t7450-bad-meta-files.sh} | 13 ++++++++++---
> > 1 file changed, 10 insertions(+), 3 deletions(-)
> > rename t/{t7415-submodule-names.sh => t7450-bad-meta-files.sh} (95%)
>
> I've never heard of a "meta file" before, but I don't tend to discover
> test scripts based on their filename anyway. :) Thanks for updating the
> test_description.I couldn't think of a better name for "files that start with .git". I almost called it "dot-git", but then I worried about confusion with the actual ".git" directory.
Show 5 quoted lines
> t7* is "the porcelainish commands concerning the working tree". Should > this go in t1* (basic commands concerning database) instead? > > t745* is unused number space so this at least won't hit any conflicts, > so fwiw
We've generally tried to order tests so that basic functionality in some area comes before more advanced. So I tried to put these specialty .gitmodules tests after the basic submodule tests (and likewise after any attribute or gitignore tests).
In practice, I doubt it matters that much. We don't tend to run the test suite serially in order these days anyway, so the notion that finding a bug in an early test might save you CPU time or time spent reading error messages likely no longer applies.
-Peff