git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH 2/4] t7401: change test_i18ncmp syntax for clarity

From
Shourya Shukla <shouryashukla.oo@gmail.com>
Date
Jul 26, 2020, 14:25 UTC
Message-ID
<20200726142553.42545-3-shouryashukla.oo@gmail.com>
In-Reply-To
<20200726142553.42545-1-shouryashukla.oo@gmail.com>

Change the test_i18ncmp syntax from 'test_i18ncmp actual expected' to 'test_i18ncmp expected actual' to align it with the convention followed by other tests in the test script.

Mentored-by: Christian Couder <chriscool@tuxfamily.org>
Mentored-by: Kaartic Sivaraam <kaartic.sivaraam@gmail.com>
Signed-off-by: Shourya Shukla <shouryashukla.oo@gmail.com>
---
 t/t7401-submodule-summary.sh | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/t/t7401-submodule-summary.sh b/t/t7401-submodule-summary.sh
index 4439fb7c17..18fefdb0ba 100755
--- a/t/t7401-submodule-summary.sh
+++ b/t/t7401-submodule-summary.sh
@@ -183,7 +183,7 @@ test_expect_success 'typechanged submodule(submodule->blob), --cached' "
   < Add foo5
 
 EOF
-	test_i18ncmp actual expected
+	test_i18ncmp expected actual
 "
 
 test_expect_success 'typechanged submodule(submodule->blob), --files' "
@@ -193,7 +193,7 @@ test_expect_success 'typechanged submodule(submodule->blob), --files' "
   > Add foo5
 
 EOF
-	test_i18ncmp actual expected
+	test_i18ncmp expected actual
 "
 
 rm -rf sm1 &&
@@ -204,7 +204,7 @@ test_expect_success 'typechanged submodule(submodule->blob)' "
 * sm1 $head4(submodule)->$head5(blob):
 
 EOF
-	test_i18ncmp actual expected
+	test_i18ncmp expected actual
 "
 
 rm -f sm1 &&
@@ -217,7 +217,7 @@ test_expect_success 'nonexistent commit' "
   Warn: sm1 doesn't contain commit $head4_full
 
 EOF
-	test_i18ncmp actual expected
+	test_i18ncmp expected actual
 "
 
 commit_file
-- 
2.27.0
Previous: Shourya ShuklaNext: Shourya Shukla
Message 3 of 5 in “t7401: modernize, cleanup and warn”
  1. Shourya ShuklaJul 26, 2020
  2. 1/4 t7401: modernize styleShourya Shukla, Jul 26, 2020
  3. 2/4 t7401: change test_i18ncmp syntax for clarityShourya Shukla, Jul 26, 2020
  4. 3/4 t7401: ensure uniformity in the '--for-status' testShourya Shukla, Jul 26, 2020
  5. 4/4 t7401: add a WARNING and a NEEDSWORKShourya Shukla, Jul 26, 2020

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.