git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[GSoC][PATCH 0/4] t7401: modernize, cleanup and warn

From
Shourya Shukla <shouryashukla.oo@gmail.com>
Date
Jul 26, 2020, 14:25 UTC
Message-ID
<20200726142553.42545-1-shouryashukla.oo@gmail.com>
Greetings,

The current phase of my GSoC project involves porting 'git submodule summary' from shell to C. While doing so, I, along with my mentors Christian and Kaartic noticed some discrepancies in the test script when trying to add a couple of tests to it. Though the test works perfectly for my C port of 'summary', there were some unexpected behaviours when trying to some tests to it. This patch series addresses these issues in the test script by modernizing it, cleaning it up and warning about some other issues.

Chiefly about patch 4/4 (t7401: add a WARNING and a NEEDSWORK), when trying to write a test for verifying the summary output of deinitialized submodule, doing a 'git submodule deinit <path>' did not bear any fruit since the submodule never really got deinitialized. The deinit documentation states that:

	Unregister the given submodules, i.e. remove the whole
	submodule.$name section from .git/config together with
	their work tree.

Something which was not actually happening in the test. It appeared that the reason for the deinit issue is that the test script uses 'git add' to add submodules instead of the command 'git submodule add'.

This behaviour also prompted the need to design a new test script to have a testing of some niche cases such as those stated before, but this is something that will be covered in the patch series responsible for porting the 'summary' subcommand to C.

Comments and reviews are appreciated.

Thanks, Shourya Shukla

Shourya Shukla (4):
  t7401: modernize style
  t7401: change test_i18ncmp syntax for clarity
  t7401: ensure uniformity in the '--for-status' test
  t7401: add a WARNING and a NEEDSWORK
 t/t7401-submodule-summary.sh | 26 +++++++++++++++++---------
 1 file changed, 17 insertions(+), 9 deletions(-)
-- 
2.27.0
Next: Shourya Shukla
Message 1 of 5 in “t7401: modernize, cleanup and warn”
  1. Shourya ShuklaJul 26, 2020
  2. 1/4 t7401: modernize styleShourya Shukla, Jul 26, 2020
  3. 2/4 t7401: change test_i18ncmp syntax for clarityShourya Shukla, Jul 26, 2020
  4. 3/4 t7401: ensure uniformity in the '--for-status' testShourya Shukla, Jul 26, 2020
  5. 4/4 t7401: add a WARNING and a NEEDSWORKShourya Shukla, Jul 26, 2020

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.