Updated since v2:
* Allow trailing colon in 'key=' argument
* Clarify documentation on how matching is done
* Rename option to "valueonly"
* Make trailing matching a callback function
* Avoid copying match string
* Simplify generation of "expected" in tests
* Rename function to strbuf_expand_literal_cb
* cocci suggested fixes
Anders Waldenborg (5):
pretty: single return path in %(trailers) handling
pretty: allow showing specific trailers
pretty: add support for "valueonly" option in %(trailers)
strbuf: separate callback for strbuf_expand:ing literals
pretty: add support for separator option in %(trailers)
Documentation/pretty-formats.txt | 26 ++++++++---
pretty.c | 68 ++++++++++++++++++++++------
strbuf.c | 21 +++++++++
strbuf.h | 8 ++++
t/t4205-log-pretty-formats.sh | 78 ++++++++++++++++++++++++++++++++
trailer.c | 25 ++++++++--
trailer.h | 4 ++
7 files changed, 206 insertions(+), 24 deletions(-)