git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: Git trademark status and policy

From
David Aguilar <davvid@gmail.com>
Date
Oct 24, 2018, 07:55 UTC
Message-ID
<20181024075533.GA11043@gmail.com>
In-Reply-To
<20180918182222.GA24448@sigill.intra.peff.net>
On Tue, Sep 18, 2018 at 02:22:22PM -0400, Jeff King wrote:
Show 34 quoted lines
> On Mon, Sep 17, 2018 at 11:25:31AM +0200, Christian Couder wrote:
> 
> > > (Also, to be clear, this is all _only_ about "Git Cola". The "git-cola"
> > > command is explicitly OK in the policy because that's how commands
> > > work).
> > 
> > I agree about "git-cola" though I wonder about "git-dag" as this is
> > another command used by the project that is more generic. For example
> > I could imagine that, if we wanted to provide a shortcut for `git log
> > --graph --decorate --oneline`, we might want to use `git dag`.
> > 
> > I guess we can still recommend to change it if possible, though we can
> > also acknowledge that, as our recommendation comes very late (too
> > late?), it is just a "weak" recommendation.
> 
> Yeah, I agree with you, though I think it is a separate issue. "git-dag"
> is explicitly OK in the trademark policy, and they are not using "Git
> Dag" in any recognizable way.
> 
> So I think there is no trademark issue, but "git-dag" is probably just
> not a great idea in general, because the namespace is open and it is
> likely to get stomped by some other project. Or git itself. Or it may
> even be annoying for users who have a "git dag" alias (on-disk commands
> always override aliases).
> 
> So I think we should generally recommend against such generic names
> during the naming phase. At this point, I'm not sure the pain of
> changing now is any less than the pain of changing later if and when
> there's a conflict.
> 
> I think I'm actually violently agreeing with you, but I wanted to make
> it clear. :) (And everything else in your email seemed sensible, too).
> 
> -Peff

Thanks for the recommendation. I'm open to changing the name in a future major release. For users that already use the short "dag" name, we can transition over to something else if it's relatively short and sweet.

Maybe a better name would be "git-kcola" (a nod to gitk), or "git-vdag" for "visual DAG"? Any sugs? I'm terrible at naming things, but I do refrain from using additional "git-*" names beyond these two for the project. I kinda like "vdag" since it's easy to type, and nearby the existing "dag" name.

There's also one more script, but it's never installed in the users's $PATH and is more of an internal implementation detail. Git Cola includes a GIT_SEQUENCE_EDITOR-compatible "git-xbase" command that provides a visual interactive rebase feature. That command should probably be renamed to "cola-git-seq-editor" to make that clearer, and also to open up the possibility of installing it in bin/ in the future since it is useful on its own.

The rationale for two commands is that worktree diff+commit and history inspection are our two primary use-cases. Everything else is provided as a sub-command, "git cola rebase", "git cola stash", etc. so there's not much pressure to add more top-level names, just these two.

Thoughts?
-- 
David
Previous: Jeff KingNext: Jeff King
Message 9 of 12 in “Git trademark status and policy”
  1. Jeff KingFeb 2, 2017
  2. G. Sylvie DaviesFeb 21, 2017
  3. Jeff KingFeb 21, 2017
  4. G. Sylvie DaviesFeb 22, 2017
  5. David AguilarSep 16, 2018
  6. Jeff KingSep 17, 2018
  7. Christian CouderSep 17, 2018
  8. Jeff KingSep 18, 2018
  9. David AguilarOct 24, 2018
  10. Jeff KingOct 25, 2018
  11. Junio C HamanoSep 17, 2018
  12. Jeff KingSep 18, 2018

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.