Re: [PATCH 2/3] transport.c: introduce core.alternateRefsCommand
- From
Taylor Blau <me@ttaylorr.com>
- Date
- Sep 21, 2018, 17:48 UTC
- Message-ID
- <20180921174825.GA17718@syl>
- In-Reply-To
- <xmqqlg7ux0st.fsf@gitster-ct.c.googlers.com>
On Fri, Sep 21, 2018 at 09:39:14AM -0700, Junio C Hamano wrote:
Show 8 quoted lines
> Taylor Blau <ttaylorr@github.com> writes:
>
> > +extract_haves () {
> > + depacketize - | grep -o '^.* \.have'
>
> Not portable, isn't it?
>
> cf. http://pubs.opengroup.org/onlinepubs/9699919799/utilities/grep.htmlGood catch. Definitely not portable, per the link that you shared above.
Since 'depacketize()' will give us a "\0", we can pull it and anything after it out with 'sed', instead. Any lines that don't contain a "\0" only contain an OID and the literal, ".have", and are fine as-is.
Something like this:
extract_haves () {
depacketize - | grep '^.* \.have' | sed -e 's/\\0.*$//g'
}Harder to read--at least for me--but infinitely more portable.
I'll wait until a little later today, and then send you v2. Thanks for reviewing :-).
Thanks, Taylor