Re: [RFC PATCH 1/1] completion: load completion file for external subcommand
- From
Florian Gamböck <mail@floga.de>
- Date
- Apr 10, 2018, 09:37 UTC
- Message-ID
- <20180410093749.GA8706@arbeitsviech>
- In-Reply-To
- <xmqq8t9w591b.fsf@gitster-ct.c.googlers.com>
On 2018-04-10 07:06, Junio C Hamano wrote:
> Florian Gamböck <mail@floga.de> writes: >> Does my reasoning make sense? > > Not at all.
:-( That actually hurt a bit.
Show 11 quoted lines
> But ... > >> I mean, the result will be exactly the same, we are clearly only >> talking about readability here. > > ... I agree, and I also think the "readability" is not absolute > anyway. > > FWIW, personally I'd find "if $completion_func does not yet exist and > a way to dynload stuff exists, then use that way to load it from an > external file" the most natural way to express what you are doing.
Then let's go with that. Maybe I am overthinking things here and re-wording doesn't hurt.
I'll send a new patch version later this day, including the commit message re-wording suggestion from Stefan.
Thank you for your feedback!
-- Regards Florian