Re: [RFC PATCH 1/1] completion: load completion file for external subcommand
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Apr 9, 2018, 22:06 UTC
- Message-ID
- <xmqq8t9w591b.fsf@gitster-ct.c.googlers.com>
- In-Reply-To
- <20180409133627.GA25078@arbeitsviech>
Florian Gamböck <mail@floga.de> writes:
Show 11 quoted lines
> On 2018-04-09 18:36, Junio C Hamano wrote: >> Florian Gamböck <mail@floga.de> writes: >> >> > Good point. I could go even further and ditch the if-construct: >> > >> > ! declare -f $completion_func && declare -f __load_completion && >> > __load_completion "git-$command" >> >> I personally find that a lot harder to read than if/then/fi. > ... > Does my reasoning make sense?
Not at all. But ...
> I mean, the result will be exactly the same, we are clearly only > talking about readability here.
... I agree, and I also think the "readability" is not absolute anyway.
FWIW, personally I'd find "if $completion_func does not yet exist and a way to dynload stuff exists, then use that way to load it from an external file" the most natural way to express what you are doing.