Re: [PATCH 16/27] sha1_file: add repository argument to sha1_file_name
- From
- Brandon Williams <bmwill@google.com>
- Date
- Feb 22, 2018, 00:51 UTC
- Message-ID
- <20180222005149.GH127348@google.com>
- In-Reply-To
- <20180221015430.96054-17-sbeller@google.com>
On 02/20, Stefan Beller wrote:
Show 10 quoted lines
> Add a repository argument to allow sha1_file_name callers to be more > specific about which repository to handle. This is a small mechanical > change; it doesn't change the implementation to handle repositories > other than the_repository yet. > > As with the previous commits, use a macro to catch callers passing a > repository other than the_repository at compile time. > > While at it, move the declaration to object-store.h, where it should > be easier to find.
Seems like we may want to make a sha1-file.h or an oid-file.h or something like that at some point as that seems like a better place for the function than in the object-store.h file?
-- Brandon Williams