git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH v2 26/33] merge-recursive: when comparing files, don't include trees

From
Elijah Newren <newren@gmail.com>
Date
Nov 20, 2017, 22:02 UTC
Message-ID
<20171120220209.15111-27-newren@gmail.com>
In-Reply-To
<20171120220209.15111-1-newren@gmail.com>

get_renames() would look up stage data that already existed (populated in get_unmerged(), taken from whatever unpack_trees() created), and if it didn't exist, would call insert_stage_data() to create the necessary entry for the given file. The insert_stage_data() fallback becomes much more important for directory rename detection, because that creates a mechanism to have a file in the resulting merge that didn't exist on either side of history. However, insert_stage_data(), due to calling get_tree_entry() loaded up trees as readily as files. We aren't interested in comparing trees to files; the D/F conflict handling is done elsewhere. This code is just concerned with what entries existed for a given path on the different sides of the merge, so create a get_tree_entry_if_blob() helper function and use it.

Signed-off-by: Elijah Newren <newren@gmail.com>
---
 merge-recursive.c | 27 +++++++++++++++++++++------
 1 file changed, 21 insertions(+), 6 deletions(-)
diff --git a/merge-recursive.c b/merge-recursive.c
index 6a17bcee33..3b1fa352db 100644
--- a/merge-recursive.c
+++ b/merge-recursive.c
@@ -418,6 +418,21 @@ static void get_files_dirs(struct merge_options *o, struct tree *tree)
 	read_tree_recursive(tree, "", 0, 0, &match_all, save_files_dirs, o);
 }
 
+static int get_tree_entry_if_blob(const unsigned char *tree,
+				  const char *path,
+				  unsigned char *hashy,
+				  unsigned int *mode_o)
+{
+	int ret;
+
+	ret = get_tree_entry(tree, path, hashy, mode_o);
+	if (S_ISDIR(*mode_o)) {
+		hashcpy(hashy, null_sha1);
+		*mode_o = 0;
+	}
+	return ret;
+}
+
 /*
  * Returns an index_entry instance which doesn't have to correspond to
  * a real cache entry in Git's index.
@@ -428,12 +443,12 @@ static struct stage_data *insert_stage_data(const char *path,
 {
 	struct string_list_item *item;
 	struct stage_data *e = xcalloc(1, sizeof(struct stage_data));
-	get_tree_entry(o->object.oid.hash, path,
-			e->stages[1].oid.hash, &e->stages[1].mode);
-	get_tree_entry(a->object.oid.hash, path,
-			e->stages[2].oid.hash, &e->stages[2].mode);
-	get_tree_entry(b->object.oid.hash, path,
-			e->stages[3].oid.hash, &e->stages[3].mode);
+	get_tree_entry_if_blob(o->object.oid.hash, path,
+			       e->stages[1].oid.hash, &e->stages[1].mode);
+	get_tree_entry_if_blob(a->object.oid.hash, path,
+			       e->stages[2].oid.hash, &e->stages[2].mode);
+	get_tree_entry_if_blob(b->object.oid.hash, path,
+			       e->stages[3].oid.hash, &e->stages[3].mode);
 	item = string_list_insert(entries, path);
 	item->util = e;
 	return e;
-- 
2.15.0.309.g00c152f825
Previous: Elijah NewrenNext: Elijah Newren
Message 14 of 34 in “Add directory rename detection to git”
  1. 00/33 Add directory rename detection to gitElijah Newren, Nov 20, 2017
  2. 04/33 directory rename detection: basic testcasesElijah Newren, Nov 20, 2017
  3. 06/33 directory rename detection: testcases to avoid taking detection too farElijah Newren, Nov 20, 2017
  4. 24/33 merge-recursive: add computation of collisions due to dir rename & mergingElijah Newren, Nov 20, 2017
  5. 22/33 merge-recursive: check for directory level conflictsElijah Newren, Nov 20, 2017
  6. 25/33 merge-recursive: check for file level conflicts then get new nameElijah Newren, Nov 20, 2017
  7. 29/33 merge-recursive: fix overwriting dirty files involved in renamesElijah Newren, Nov 20, 2017
  8. 30/33 merge-recursive: fix remaining directory rename + dirty overwrite casesElijah Newren, Nov 20, 2017
  9. 31/33 directory rename detection: new testcases showcasing a pair of bugsElijah Newren, Nov 20, 2017
  10. 17/33 merge-recursive: fix leaks of allocated renames and diff_filepairsElijah Newren, Nov 20, 2017
  11. 33/33 merge-recursive: ensure we write updates for directory-renamed fileElijah Newren, Nov 20, 2017
  12. 28/33 merge-recursive: avoid clobbering untracked files with directory renamesElijah Newren, Nov 20, 2017
  13. 18/33 merge-recursive: make !o->detect_rename codepath more obviousElijah Newren, Nov 20, 2017
  14. 26/33 merge-recursive: when comparing files, don't include treesElijah Newren, Nov 20, 2017
  15. 11/33 directory rename detection: testcases exploring possibly suboptimal mergesElijah Newren, Nov 20, 2017
  16. 32/33 merge-recursive: avoid spurious rename/rename conflict from dir renamesElijah Newren, Nov 20, 2017
  17. 21/33 merge-recursive: add get_directory_renames()Elijah Newren, Nov 20, 2017
  18. 10/33 directory rename detection: more involved edge/corner testcasesElijah Newren, Nov 20, 2017
  19. 27/33 merge-recursive: apply necessary modifications for directory renamesElijah Newren, Nov 20, 2017
  20. 23/33 merge-recursive: add a new hashmap for storing file collisionsElijah Newren, Nov 20, 2017
  21. 20/33 merge-recursive: add a new hashmap for storing directory renamesElijah Newren, Nov 20, 2017
  22. 02/33 merge-recursive: fix logic ordering issueElijah Newren, Nov 20, 2017
  23. 12/33 directory rename detection: miscellaneous testcases to complete coverageElijah Newren, Nov 20, 2017
  24. 05/33 directory rename detection: directory splitting testcasesElijah Newren, Nov 20, 2017
  25. 19/33 merge-recursive: split out code for determining diff_filepairsElijah Newren, Nov 20, 2017
  26. 15/33 merge-recursive: move the get_renames() functionElijah Newren, Nov 20, 2017
  27. 16/33 merge-recursive: introduce new functions to handle rename logicElijah Newren, Nov 20, 2017
  28. 13/33 directory rename detection: tests for handling overwriting untracked filesElijah Newren, Nov 20, 2017
  29. 14/33 directory rename detection: tests for handling overwriting dirty filesElijah Newren, Nov 20, 2017
  30. 03/33 merge-recursive: add explanation for src_entry and dst_entryElijah Newren, Nov 20, 2017
  31. 01/33 Tighten and correct a few testcases for merging and cherry-pickingElijah Newren, Nov 20, 2017
  32. 09/33 directory rename detection: testcases checking which side did the renameElijah Newren, Nov 20, 2017
  33. 07/33 directory rename detection: partially renamed directory testcase/discussionElijah Newren, Nov 20, 2017
  34. 08/33 directory rename detection: files/directories in the way of some renamesElijah Newren, Nov 20, 2017

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.