git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH v2 19/33] merge-recursive: split out code for determining diff_filepairs

From
Elijah Newren <newren@gmail.com>
Date
Nov 20, 2017, 22:01 UTC
Message-ID
<20171120220209.15111-20-newren@gmail.com>
In-Reply-To
<20171120220209.15111-1-newren@gmail.com>

Create a new function, get_diffpairs() to compute the diff_filepairs between two trees. While these are currently only used in get_renames(), I want them to be available to some new functions. No actual logic changes yet.

Signed-off-by: Elijah Newren <newren@gmail.com>
---
 merge-recursive.c | 87 +++++++++++++++++++++++++++++++++++++++++--------------
 1 file changed, 65 insertions(+), 22 deletions(-)
diff --git a/merge-recursive.c b/merge-recursive.c
index be04e61c10..7bcadaef13 100644
--- a/merge-recursive.c
+++ b/merge-recursive.c
@@ -1312,24 +1312,15 @@ static int conflict_rename_rename_2to1(struct merge_options *o,
 }
 
 /*
- * Get information of all renames which occurred between 'o_tree' and
- * 'tree'. We need the three trees in the merge ('o_tree', 'a_tree' and
- * 'b_tree') to be able to associate the correct cache entries with
- * the rename information. 'tree' is always equal to either a_tree or b_tree.
+ * Get the diff_filepairs changed between o_tree and tree.
  */
-static struct string_list *get_renames(struct merge_options *o,
-				       struct tree *tree,
-				       struct tree *o_tree,
-				       struct tree *a_tree,
-				       struct tree *b_tree,
-				       struct string_list *entries)
+static struct diff_queue_struct *get_diffpairs(struct merge_options *o,
+					       struct tree *o_tree,
+					       struct tree *tree)
 {
-	int i;
-	struct string_list *renames;
+	struct diff_queue_struct *ret;
 	struct diff_options opts;
 
-	renames = xcalloc(1, sizeof(struct string_list));
-
 	diff_setup(&opts);
 	opts.flags.recursive = 1;
 	opts.flags.rename_empty = 0;
@@ -1345,10 +1336,43 @@ static struct string_list *get_renames(struct merge_options *o,
 	diffcore_std(&opts);
 	if (opts.needed_rename_limit > o->needed_rename_limit)
 		o->needed_rename_limit = opts.needed_rename_limit;
-	for (i = 0; i < diff_queued_diff.nr; ++i) {
+
+	ret = malloc(sizeof(struct diff_queue_struct));
+	ret->queue = diff_queued_diff.queue;
+	ret->nr = diff_queued_diff.nr;
+	/* Ignore diff_queued_diff.alloc; we won't be changing size at all */
+
+	opts.output_format = DIFF_FORMAT_NO_OUTPUT;
+	diff_queued_diff.nr = 0;
+	diff_queued_diff.queue = NULL;
+	diff_flush(&opts);
+	return ret;
+}
+
+/*
+ * Get information of all renames which occurred in 'pairs', making use of
+ * any implicit directory renames inferred from the other side of history.
+ * We need the three trees in the merge ('o_tree', 'a_tree' and 'b_tree')
+ * to be able to associate the correct cache entries with the rename
+ * information; tree is always equal to either a_tree or b_tree.
+ */
+static struct string_list *get_renames(struct merge_options *o,
+				       struct diff_queue_struct *pairs,
+				       struct tree *tree,
+				       struct tree *o_tree,
+				       struct tree *a_tree,
+				       struct tree *b_tree,
+				       struct string_list *entries)
+{
+	int i;
+	struct string_list *renames;
+
+	renames = xcalloc(1, sizeof(struct string_list));
+
+	for (i = 0; i < pairs->nr; ++i) {
 		struct string_list_item *item;
 		struct rename *re;
-		struct diff_filepair *pair = diff_queued_diff.queue[i];
+		struct diff_filepair *pair = pairs->queue[i];
 
 		if (pair->status != 'R') {
 			diff_free_filepair(pair);
@@ -1373,9 +1397,6 @@ static struct string_list *get_renames(struct merge_options *o,
 		item = string_list_insert(renames, pair->one->path);
 		item->util = re;
 	}
-	opts.output_format = DIFF_FORMAT_NO_OUTPUT;
-	diff_queued_diff.nr = 0;
-	diff_flush(&opts);
 	return renames;
 }
 
@@ -1646,15 +1667,37 @@ static int handle_renames(struct merge_options *o,
 			  struct string_list *entries,
 			  struct rename_info *ri)
 {
+	struct diff_queue_struct *head_pairs, *merge_pairs;
+	int clean;
+
 	if (!o->detect_rename) {
 		ri->head_renames = NULL;
 		ri->merge_renames = NULL;
 		return 1;
 	}
 
-	ri->head_renames  = get_renames(o, head, common, head, merge, entries);
-	ri->merge_renames = get_renames(o, merge, common, head, merge, entries);
-	return process_renames(o, ri->head_renames, ri->merge_renames);
+	head_pairs = get_diffpairs(o, common, head);
+	merge_pairs = get_diffpairs(o, common, merge);
+
+	ri->head_renames  = get_renames(o, head_pairs, head,
+					 common, head, merge, entries);
+	ri->merge_renames = get_renames(o, merge_pairs, merge,
+					 common, head, merge, entries);
+	clean = process_renames(o, ri->head_renames, ri->merge_renames);
+
+cleanup:
+	/*
+	 * Some cleanup is deferred until cleanup_renames() because the
+	 * data structures are still needed and referenced in
+	 * process_entry().  But there are a few things we can free now.
+	 */
+
+	free(head_pairs->queue);
+	free(head_pairs);
+	free(merge_pairs->queue);
+	free(merge_pairs);
+
+	return clean;
 }
 
 static void cleanup_rename(struct string_list *rename)
-- 
2.15.0.309.g00c152f825
Previous: Elijah NewrenNext: Elijah Newren
Message 25 of 34 in “Add directory rename detection to git”
  1. 00/33 Add directory rename detection to gitElijah Newren, Nov 20, 2017
  2. 04/33 directory rename detection: basic testcasesElijah Newren, Nov 20, 2017
  3. 06/33 directory rename detection: testcases to avoid taking detection too farElijah Newren, Nov 20, 2017
  4. 24/33 merge-recursive: add computation of collisions due to dir rename & mergingElijah Newren, Nov 20, 2017
  5. 22/33 merge-recursive: check for directory level conflictsElijah Newren, Nov 20, 2017
  6. 25/33 merge-recursive: check for file level conflicts then get new nameElijah Newren, Nov 20, 2017
  7. 29/33 merge-recursive: fix overwriting dirty files involved in renamesElijah Newren, Nov 20, 2017
  8. 30/33 merge-recursive: fix remaining directory rename + dirty overwrite casesElijah Newren, Nov 20, 2017
  9. 31/33 directory rename detection: new testcases showcasing a pair of bugsElijah Newren, Nov 20, 2017
  10. 17/33 merge-recursive: fix leaks of allocated renames and diff_filepairsElijah Newren, Nov 20, 2017
  11. 33/33 merge-recursive: ensure we write updates for directory-renamed fileElijah Newren, Nov 20, 2017
  12. 28/33 merge-recursive: avoid clobbering untracked files with directory renamesElijah Newren, Nov 20, 2017
  13. 18/33 merge-recursive: make !o->detect_rename codepath more obviousElijah Newren, Nov 20, 2017
  14. 26/33 merge-recursive: when comparing files, don't include treesElijah Newren, Nov 20, 2017
  15. 11/33 directory rename detection: testcases exploring possibly suboptimal mergesElijah Newren, Nov 20, 2017
  16. 32/33 merge-recursive: avoid spurious rename/rename conflict from dir renamesElijah Newren, Nov 20, 2017
  17. 21/33 merge-recursive: add get_directory_renames()Elijah Newren, Nov 20, 2017
  18. 10/33 directory rename detection: more involved edge/corner testcasesElijah Newren, Nov 20, 2017
  19. 27/33 merge-recursive: apply necessary modifications for directory renamesElijah Newren, Nov 20, 2017
  20. 23/33 merge-recursive: add a new hashmap for storing file collisionsElijah Newren, Nov 20, 2017
  21. 20/33 merge-recursive: add a new hashmap for storing directory renamesElijah Newren, Nov 20, 2017
  22. 02/33 merge-recursive: fix logic ordering issueElijah Newren, Nov 20, 2017
  23. 12/33 directory rename detection: miscellaneous testcases to complete coverageElijah Newren, Nov 20, 2017
  24. 05/33 directory rename detection: directory splitting testcasesElijah Newren, Nov 20, 2017
  25. 19/33 merge-recursive: split out code for determining diff_filepairsElijah Newren, Nov 20, 2017
  26. 15/33 merge-recursive: move the get_renames() functionElijah Newren, Nov 20, 2017
  27. 16/33 merge-recursive: introduce new functions to handle rename logicElijah Newren, Nov 20, 2017
  28. 13/33 directory rename detection: tests for handling overwriting untracked filesElijah Newren, Nov 20, 2017
  29. 14/33 directory rename detection: tests for handling overwriting dirty filesElijah Newren, Nov 20, 2017
  30. 03/33 merge-recursive: add explanation for src_entry and dst_entryElijah Newren, Nov 20, 2017
  31. 01/33 Tighten and correct a few testcases for merging and cherry-pickingElijah Newren, Nov 20, 2017
  32. 09/33 directory rename detection: testcases checking which side did the renameElijah Newren, Nov 20, 2017
  33. 07/33 directory rename detection: partially renamed directory testcase/discussionElijah Newren, Nov 20, 2017
  34. 08/33 directory rename detection: files/directories in the way of some renamesElijah Newren, Nov 20, 2017

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.