Re: [PATCH 2/2] commit: don't check for space twice when looking for header
- From
Jeff King <peff@peff.net>
- Date
- Feb 25, 2017, 20:15 UTC
- Message-ID
- <20170225201522.uan52fwey6zjosym@sigill.intra.peff.net>
- In-Reply-To
- <b1d5c882-38b8-dd2d-2e5f-aafb8dfada81@web.de>
On Sat, Feb 25, 2017 at 08:27:40PM +0100, René Scharfe wrote:
Show 5 quoted lines
> Both standard_header_field() and excluded_header_field() check if > there's a space after the buffer that's handed to them. We already > check in the caller if that space is present. Don't bother calling > the functions if it's missing, as they are guaranteed to return 0 in > that case, and remove the now redundant checks from them.
Makes sense, and I couldn't spot any errors in your logic or in the code.
Show 12 quoted lines
> static inline int standard_header_field(const char *field, size_t len)
> {
> - return ((len == 4 && !memcmp(field, "tree ", 5)) ||
> - (len == 6 && !memcmp(field, "parent ", 7)) ||
> - (len == 6 && !memcmp(field, "author ", 7)) ||
> - (len == 9 && !memcmp(field, "committer ", 10)) ||
> - (len == 8 && !memcmp(field, "encoding ", 9)));
> + return ((len == 4 && !memcmp(field, "tree", 4)) ||
> + (len == 6 && !memcmp(field, "parent", 6)) ||
> + (len == 6 && !memcmp(field, "author", 6)) ||
> + (len == 9 && !memcmp(field, "committer", 9)) ||
> + (len == 8 && !memcmp(field, "encoding", 8)));Unrelated, but this could probably be spelled with a macro and strlen() to avoid the magic numbers. It would probably be measurably slower for a compiler which doesn't pre-compute strlen() on a string literal, though.
-Peff