Re: [PATCH v2 1/3] serialize collection of changed submodules
On Wed, Oct 12, 2016 at 10:18:28AM -0700, Junio C Hamano wrote:
Show 18 quoted lines
> Heiko Voigt <hvoigt@hvoigt.net> writes:
>
> > Which seems quite extensively long for a static function so how about
> > we shorten it a bit and add a comment:
> >
> > /* lookup or create commit object list for submodule */
> > get_commit_objects_for_submodule_path(...
>
> Or you can even lose "get_" and "path", I guess. You are not even
> "getting" commits but the array that holds them, so the caller can
> use it to "get" one of them or it can even use it to "put" a new
> one, no? "get-commit-objects" is a misnomer in that sense. Either
> one of
>
> get_submodule_commits_array()
> submodule_commits()
>
> perhaps? I dunno.
I like the last one. Will use 'submodule_commits()'.
Cheers Heiko