[PATCH 21/28] attr.c: rename a local variable check
- From
Stefan Beller <sbeller@google.com>
- Date
- Oct 11, 2016, 00:21 UTC
- Message-ID
- <20161011002115.23312-22-sbeller@google.com>
- In-Reply-To
- <20161011002115.23312-1-sbeller@google.com>
From: Junio C Hamano <gitster@pobox.com>
Throughout this series, we are trying to use "check" to name an instance of "git_attr_check" structure; let's rename a "check" that refers to an array whose elements are git_attr_check_elem to avoid confusion.
Signed-off-by: Junio C Hamano <gitster@pobox.com> Signed-off-by: Stefan Beller <sbeller@google.com> --- attr.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/attr.c b/attr.c index c1d5222..abf23d8 100644 --- a/attr.c +++ b/attr.c @@ -682,12 +682,12 @@ static int macroexpand_one(int attr_nr, int rem); static int fill_one(const char *what, struct match_attr *a, int rem) { - struct git_attr_check_elem *check = check_all_attr; + struct git_attr_check_elem *celem = check_all_attr; int i; for (i = a->num_attr - 1; 0 < rem && 0 <= i; i--) { struct git_attr *attr = a->state[i].attr; - const char **n = &(check[attr->attr_nr].value); + const char **n = &(celem[attr->attr_nr].value); const char *v = a->state[i].setto; if (*n == ATTR__UNKNOWN) {
-- 2.10.1.382.ga23ca1b.dirty