git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 1/3] strbuf: make stripspace() part of strbuf

From
Tobias Klauser <tklauser@distanz.ch>
Date
Oct 16, 2015, 07:09 UTC
Message-ID
<20151016070953.GJ11304@distanz.ch>
In-Reply-To
<xmqqsi5cghke.fsf@gitster.mtv.corp.google.com>
Thanks for the review.
On 2015-10-15 at 19:36:17 +0200, Junio C Hamano <gitster@pobox.com> wrote:
Show 20 quoted lines
> Tobias Klauser <tklauser@distanz.ch> writes:
> 
> > Rename stripspace() to strbuf_stripspace() and move it to the strbuf
> > module as suggested in [1].
> >
> > Also switch all current users of stripspace() to the new function name
> > and  keep a temporary wrapper inline function for topic branches still
> > using stripspace().
> >
> > [1] https://git.wiki.kernel.org/index.php/SmallProjectsIdeas#make_.27stripspace.28.29.27_part_of_strbuf
> 
> I think Matthieu already mentioned this, but please explain why it
> is a good idea to do this in your own words here, without forcing
> readers to go to other places to find out.  Giving credit to an
> external page for giving you an inspiration to do something is good,
> but the proposed log message needs to justify itself.  In other
> words, when you are challenged to defend this change, you are not
> allowed to say "SmallProjectIdeas page said it is a good thing to
> do.  I just did it without questioning it." ;-)  Instead you are
> expected to justify it yourself.

Yes, makes sense. I'll adjust the commit message for v2 to justify the change for itself and move the link below --- as Matthieu suggested.

Show 11 quoted lines
> > Signed-off-by: Tobias Klauser <tklauser@distanz.ch>
> > ---
> 
> A good rule of thumb to see if it is a good time to do this kind of
> change is to do this:
> 
> 	$ git log -p maint..pu | grep stripspace
> 
> which shows only one mention in a context, so this change may cause
> textual conflict with something else somewhere nearby but won't hurt
> other topics in flight.
Ok, thanks for the hint. I'll check again before resubmitting v2.
Thanks
Previous: Junio C HamanoNext: Tobias Klauser
Message 7 of 19 in “stripspace: Implement and use --count-lines option”
  1. 0/3 stripspace: Implement and use --count-lines optionTobias Klauser, Oct 15, 2015
  2. 1/3 strbuf: make stripspace() part of strbufTobias Klauser, Oct 15, 2015
  3. Matthieu MoyOct 15, 2015
  4. Tobias KlauserOct 16, 2015
  5. Matthieu MoyOct 15, 2015
  6. Junio C HamanoOct 15, 2015
  7. Tobias KlauserOct 16, 2015
  8. 2/3 stripspace: Implement --count-lines optionTobias Klauser, Oct 15, 2015
  9. Matthieu MoyOct 15, 2015
  10. Tobias KlauserOct 16, 2015
  11. Tobias KlauserOct 16, 2015
  12. Matthieu MoyOct 16, 2015
  13. Junio C HamanoOct 15, 2015
  14. Tobias KlauserOct 16, 2015
  15. Junio C HamanoOct 16, 2015
  16. Tobias KlauserOct 17, 2015
  17. Matthieu MoyOct 15, 2015
  18. Tobias KlauserOct 16, 2015
  19. 3/3 git rebase -i: Use newly added --count-lines option for stripspaceTobias Klauser, Oct 15, 2015

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.