[PATCH 3/5] builtin/commit.c: use xstrdup_or_null instead of envdup
- From
Jeff King <peff@peff.net>
- Date
- Jan 13, 2015, 01:58 UTC
- Message-ID
- <20150113015832.GC18986@peff.net>
- In-Reply-To
- <20150113015427.GA5497@peff.net>
The only reason for envdup to be its own function is that we have to save the result in a temporary string. With xstrdup_or_null, we can feed the result of getenv() directly.
Signed-off-by: Jeff King <peff@peff.net> --- These ones need the temporary. Is the result more readable, or less?
builtin/commit.c | 12 +++--------- 1 file changed, 3 insertions(+), 9 deletions(-)
diff --git a/builtin/commit.c b/builtin/commit.c index 7d90c35..5cd1478 100644 --- a/builtin/commit.c +++ b/builtin/commit.c @@ -559,20 +559,14 @@ static void set_ident_var(char **buf, char *val) *buf = val; } -static char *envdup(const char *var) -{ - const char *val = getenv(var); - return val ? xstrdup(val) : NULL; -} - static void determine_author_info(struct strbuf *author_ident) { char *name, *email, *date; struct ident_split author; - name = envdup("GIT_AUTHOR_NAME"); - email = envdup("GIT_AUTHOR_EMAIL"); - date = envdup("GIT_AUTHOR_DATE"); + name = xstrdup_or_null(getenv("GIT_AUTHOR_NAME")); + email = xstrdup_or_null(getenv("GIT_AUTHOR_EMAIL")); + date = xstrdup_or_null(getenv("GIT_AUTHOR_DATE")); if (author_message) { struct ident_split ident;
-- 2.2.1.425.g441bb3c