[PATCH 1/5] git-compat-util: add xstrdup_or_null helper
- From
Jeff King <peff@peff.net>
- Date
- Jan 13, 2015, 01:57 UTC
- Message-ID
- <20150113015736.GA18986@peff.net>
- In-Reply-To
- <20150113015427.GA5497@peff.net>
It's a common idiom to duplicate a string if it is non-NULL, or pass a literal NULL through. This is already a one-liner in C, but you do have to repeat the name of the string twice. So if there's a function call, you must write:
const char *x = some_fun(...); return x ? xstrdup(x) : NULL;
instead of (with this patch) just:
return xstrdup_or_null(some_fun(...));
Signed-off-by: Jeff King <peff@peff.net> --- This example is the heart of the readability question to me. It is nice to avoid the temporary, which makes the code more direct. But it also sticks some_fun(...) inside another function, which is a little harder to read.
git-compat-util.h | 5 +++++ 1 file changed, 5 insertions(+)
diff --git a/git-compat-util.h b/git-compat-util.h index dcecd85..8157eb2 100644 --- a/git-compat-util.h +++ b/git-compat-util.h @@ -675,6 +675,11 @@ extern char *xgetcwd(void); #define REALLOC_ARRAY(x, alloc) (x) = xrealloc((x), (alloc) * sizeof(*(x))) +static inline char *xstrdup_or_null(const char *str) +{ + return str ? xstrdup(str) : NULL; +} + static inline size_t xsize_t(off_t len) { if (len > (size_t) len)
-- 2.2.1.425.g441bb3c