Re: [PATCH 2/7] move setting of object->type to alloc_* functions
- From
Jeff King <peff@peff.net>
- Date
- Jul 12, 2014, 18:05 UTC
- Message-ID
- <20140712180539.GA13806@sigill.intra.peff.net>
- In-Reply-To
- <53C149B6.7010705@ramsay1.demon.co.uk>
On Sat, Jul 12, 2014 at 03:44:06PM +0100, Ramsay Jones wrote:
Show 8 quoted lines
> > - return alloc_node(&name##_state, sizeof(type)); \ > > + return alloc_node(&name##_state, flag, sizeof(type)); \ > > } > > I don't particularly like 'flag' here. (not a massive dislike, mind you:) > > Perhaps: flag->object_type, type->node_type? > Or, if that's too verbose, maybe just: flag->type, type->node?
Me either, but as you noticed, type was taken. Your suggestions seem fine. We could also just do away with the macro as discussed earlier (we already do in the commit_node case, anyway...).
-Peff