Re: [PATCH] Define constants for lengths of object names
- From
Jonathan Nieder <jrnieder@gmail.com>
- Date
- May 1, 2014, 18:23 UTC
- Message-ID
- <20140501182304.GB9218@google.com>
- In-Reply-To
- <20140501172007.GZ9218@google.com>
Jonathan Nieder wrote:
> brian m. carlson wrote:
Show 13 quoted lines
>> --- a/object.h
>> +++ b/object.h
> [...]
>> @@ -49,7 +56,7 @@ struct object {
>> unsigned used : 1;
>> unsigned type : TYPE_BITS;
>> unsigned flags : FLAG_BITS;
>> - unsigned char sha1[20];
>> + unsigned char sha1[GIT_OID_RAWSZ];
>
> Maybe my brain has been damaged by reading code from too many C
> projects that hard-code some constants, but I find '20' easier to read
> here.That said, RAW_SHA1_BYTES would sound okay to me.
Part of the problem was how long it takes to mentally parse oid_rawsz.
Thanks, Jonathan