threads / patch / 36562

patchDefine constants for lengths of object names

Subject: [PATCH] Define constants for lengths of object names

## tl;dr

7 messages between May 1, 2014 and May 2, 2014. Diffs are folded; open one to read it.

replies: 6people: 3as markdown or json

brian m. carlson· May 1, 2014, 11:06 UTC · lore

Using preprocessor constants rather than hardcoded numbers is considered a good programming practice. Provide two constants, GIT_OID_RAWSZ and GIT_OID_HEXSZ, which are the lengths of an SHA-1 object name in bytes and hex digits, respectively. These names are the same as those used by libgit2.

Signed-off-by: brian m. carlson <sandals@crustytoothpaste.net>
---
 object.h | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)
Show changes to object.h +8 −1
diff --git a/object.h b/object.h
index 6e12f2c..f1cff2d 100644
--- a/object.h
+++ b/object.h
@@ -1,6 +1,13 @@
 #ifndef OBJECT_H
 #define OBJECT_H
 
+/*
+ * The length in bytes and in hex digits of an object name (SHA-1 value).
+ * These are the same names used by libgit2.
+ */
+#define GIT_OID_RAWSZ 20
+#define GIT_OID_HEXSZ 40
+
 struct object_list {
 	struct object *item;
 	struct object_list *next;
@@ -49,7 +56,7 @@ struct object {
 	unsigned used : 1;
 	unsigned type : TYPE_BITS;
 	unsigned flags : FLAG_BITS;
-	unsigned char sha1[20];
+	unsigned char sha1[GIT_OID_RAWSZ];
 };
 
 extern const char *typename(unsigned int type);
-- 
2.0.0.rc0
Jonathan Nieder· May 1, 2014, 17:20 UTC · re: brian m. carlson · lore

Re: [PATCH] Define constants for lengths of object names

Hi,
brian m. carlson wrote:
> --- a/object.h
> +++ b/object.h
[...]
Show 6 quoted lines
> @@ -49,7 +56,7 @@ struct object {
>  	unsigned used : 1;
>  	unsigned type : TYPE_BITS;
>  	unsigned flags : FLAG_BITS;
> -	unsigned char sha1[20];
> +	unsigned char sha1[GIT_OID_RAWSZ];

Maybe my brain has been damaged by reading code from too many C projects that hard-code some constants, but I find '20' easier to read here.

What happened to the
	struct object_id {
		unsigned char id[20];
	};
	...
	struct object {
		...
		struct object_id id;
	};
idea?

Thanks, Jonathan

Jonathan Nieder· May 1, 2014, 18:23 UTC · re: Jonathan Nieder · lore

Re: [PATCH] Define constants for lengths of object names

Jonathan Nieder wrote:
> brian m. carlson wrote:
Show 13 quoted lines
>> --- a/object.h
>> +++ b/object.h
> [...]
>> @@ -49,7 +56,7 @@ struct object {
>>  	unsigned used : 1;
>>  	unsigned type : TYPE_BITS;
>>  	unsigned flags : FLAG_BITS;
>> -	unsigned char sha1[20];
>> +	unsigned char sha1[GIT_OID_RAWSZ];
>
> Maybe my brain has been damaged by reading code from too many C
> projects that hard-code some constants, but I find '20' easier to read
> here.
That said, RAW_SHA1_BYTES would sound okay to me.
Part of the problem was how long it takes to mentally parse oid_rawsz.

Thanks, Jonathan

brian m. carlson· May 1, 2014, 23:00 UTC · re: Jonathan Nieder · lore

Re: [PATCH] Define constants for lengths of object names

On Thu, May 01, 2014 at 10:20:07AM -0700, Jonathan Nieder wrote:
Show 32 quoted lines
> Hi,
> 
> brian m. carlson wrote:
> 
> > --- a/object.h
> > +++ b/object.h
> [...]
> > @@ -49,7 +56,7 @@ struct object {
> >  	unsigned used : 1;
> >  	unsigned type : TYPE_BITS;
> >  	unsigned flags : FLAG_BITS;
> > -	unsigned char sha1[20];
> > +	unsigned char sha1[GIT_OID_RAWSZ];
> 
> Maybe my brain has been damaged by reading code from too many C
> projects that hard-code some constants, but I find '20' easier to read
> here.
> 
> What happened to the
> 
> 	struct object_id {
> 		unsigned char id[20];
> 	};
> 
> 	...
> 
> 	struct object {
> 		...
> 		struct object_id id;
> 	};
> 
> idea?

There didn't seem to be a huge amount of support for it. Also, there were concerns that some architectures might impose alignment constraints on it that made sizeof(struct object_id) != 20.

-- 
brian m. carlson / brian with sandals: Houston, Texas, US
+1 832 623 2791 | http://www.crustytoothpaste.net/~bmc | My opinion only
OpenPGP: RSA v4 4096b: 88AC E9B2 9196 305B A994 7552 F1BA 225C 0223 B187
Jonathan Nieder· May 1, 2014, 23:05 UTC · re: brian m. carlson · lore

Re: [PATCH] Define constants for lengths of object names

brian m. carlson wrote:
> On Thu, May 01, 2014 at 10:20:07AM -0700, Jonathan Nieder wrote:
Show 16 quoted lines
>> What happened to the
>>
>> 	struct object_id {
>> 		unsigned char id[20];
>> 	};
>>
>> 	...
>>
>> 	struct object {
>> 		...
>> 		struct object_id id;
>> 	};
>>
>> idea?
>
> There didn't seem to be a huge amount of support for it.

I can make up for it in enthuasiasm. Please? It's something I've wanted for a long time but never found the time to do.

>                                                           Also, there
> were concerns that some architectures might impose alignment constraints
> on it that made sizeof(struct object_id) != 20.
Sounds awful.  What architecture?

Thanks, Jonathan

Duy Nguyen· May 2, 2014, 00:15 UTC · re: Jonathan Nieder · lore

Re: [PATCH] Define constants for lengths of object names

On Fri, May 2, 2014 at 6:05 AM, Jonathan Nieder <jrnieder@gmail.com> wrote:
Show 22 quoted lines
> brian m. carlson wrote:
>> On Thu, May 01, 2014 at 10:20:07AM -0700, Jonathan Nieder wrote:
>
>>> What happened to the
>>>
>>>      struct object_id {
>>>              unsigned char id[20];
>>>      };
>>>
>>>      ...
>>>
>>>      struct object {
>>>              ...
>>>              struct object_id id;
>>>      };
>>>
>>> idea?
>>
>> There didn't seem to be a huge amount of support for it.
>
> I can make up for it in enthuasiasm.  Please?  It's something I've
> wanted for a long time but never found the time to do.

It's definitely better in the sense that the compiler will catch new "char[20]" declarations for us. It's also a lot more work.

Show 5 quoted lines
>>                                                           Also, there
>> were concerns that some architectures might impose alignment constraints
>> on it that made sizeof(struct object_id) != 20.
>
> Sounds awful.  What architecture?

No architecture was named last time if I remember correctly. But we could check "sizeof(struct object_id) == 20" in a test or something. When people scream, we can pack the struct on that particular platform?

-- 
Duy
brian m. carlson· May 2, 2014, 22:09 UTC · re: Duy Nguyen · lore

Re: [PATCH] Define constants for lengths of object names

On Fri, May 02, 2014 at 07:15:44AM +0700, Duy Nguyen wrote:
Show 7 quoted lines
> On Fri, May 2, 2014 at 6:05 AM, Jonathan Nieder <jrnieder@gmail.com> wrote:
> >
> > I can make up for it in enthuasiasm.  Please?  It's something I've
> > wanted for a long time but never found the time to do.
> 
> It's definitely better in the sense that the compiler will catch new
> "char[20]" declarations for us. It's also a lot more work.

It is. I'm going to start with a patch that introduces struct object_id and the fixed constants. Then I'm going to get a patch that compiles with lots of warnings, and then I'm going to fix all those warnings. Otherwise, the patch will simply be too enormous to review.

I'm willing to hear other suggestions for going about this, though.
> No architecture was named last time if I remember correctly. But we
> could check "sizeof(struct object_id) == 20" in a test or something.
> When people scream, we can pack the struct on that particular
> platform?

Sounds like a plan. I am not aware of any architecture that has this limitation; I've worked with x86(-64)?, 32-bit PowerPC, UltraSPARC, and ARM.

-- 
brian m. carlson / brian with sandals: Houston, Texas, US
+1 832 623 2791 | http://www.crustytoothpaste.net/~bmc | My opinion only
OpenPGP: RSA v4 4096b: 88AC E9B2 9196 305B A994 7552 F1BA 225C 0223 B187

← back to recent threads