git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v4 0/5] Disable "git status" comment prefix

From
Jonathan Nieder <jrnieder@gmail.com>
Date
Sep 6, 2013, 16:53 UTC
Message-ID
<20130906165330.GA6462@google.com>
In-Reply-To
<20130905232322.GB29351@sigill.intra.peff.net>
Jeff King wrote:
> On Thu, Sep 05, 2013 at 09:36:47PM +0200, Matthieu Moy wrote:
Show 6 quoted lines
>> I'm fine with any name actually (since it is enabled by default, people
>> don't need to know the name to benefit from the new output). Maybe
>> status.displayCommentPrefix was the best name after all.
>
> FWIW, I had the same thought as Junio. I much prefer something like
> status.displayCommentPrefix for clarity and future-proofing.

Sounds fine, but I don't understand why we'd want this to be an option with a future in the first place. Why not just fix the remaining bugs before merging to master and make it unconditional?

[...]
Show 15 quoted lines
> after:
>
>   On branch private
>   Your branch and 'origin/next' have diverged,
>   and have 472 and 59 different commits each, respectively.
>   Untracked files:
>           t/foo
>           test-obj-pool
>           test-string-pool
>           test-treap
>           test-url-normalize
>   nothing added to commit but untracked files present
>
> The blank before "Untracked files" was dropped (was this intentional? I
> didn't see any note of it in the discussion),
That's a bug.
Show 18 quoted lines
>                                               and the bottom "nothing
> added" line butts against the untracked list more obviously, because
> they now all have the same comment indentation.
>
> I wonder if it would look a little nicer as:
>
>   On branch private
>   Your branch and 'origin/next' have diverged,
>   and have 472 and 59 different commits each, respectively.
>
>   Untracked files:
>           t/foo
>           test-obj-pool
>           test-string-pool
>           test-treap
>           test-url-normalize
>
>   nothing added to commit but untracked files present
The added blank line before "nothing added" sounds like a good idea.

Thanks, Jonathan

Previous: Matthieu MoyNext: Matthieu Moy
Message 13 of 17 in “Disable "git status" comment prefix”
  1. 0/5 Disable "git status" comment prefixMatthieu Moy, Sep 5, 2013
  2. 1/5 builtin/stripspace.c: fix broken indentationMatthieu Moy, Sep 5, 2013
  3. 2/5 wt-status: use argv_array APIMatthieu Moy, Sep 5, 2013
  4. 3/5 submodule summary: ignore --for-status optionMatthieu Moy, Sep 5, 2013
  5. 4/5 status: disable display of '#' comment prefix by defaultMatthieu Moy, Sep 5, 2013
  6. 5/5 tests: don't set status.oldStyle file-wideMatthieu Moy, Sep 5, 2013
  7. Matthieu MoySep 5, 2013
  8. Junio C HamanoSep 5, 2013
  9. Matthieu MoySep 5, 2013
  10. Junio C HamanoSep 5, 2013
  11. Jeff KingSep 5, 2013
  12. Matthieu MoySep 6, 2013
  13. Jonathan NiederSep 6, 2013
  14. Matthieu MoySep 6, 2013
  15. Junio C HamanoSep 6, 2013
  16. Matthieu MoySep 6, 2013
  17. Jeff KingSep 6, 2013

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.