git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCHv4 2/4] Add infrastructure for ref namespaces

From
Josh Triplett <josh@joshtriplett.org>
Date
Jun 9, 2011, 03:38 UTC
Message-ID
<20110609033817.GB6167@leaf>
In-Reply-To
<201106081141.26994.jnareb@gmail.com>
On Wed, Jun 08, 2011 at 11:41:25AM +0200, Jakub Narebski wrote:
Show 27 quoted lines
> On Fri, 3 June 2011, Josh Triplett wrote:
> > On Fri, Jun 03, 2011 at 01:35:34AM -0700, Jakub Narebski wrote:
> > > Jamey Sharp <jamey@minilop.net> writes:
> > > 
> > > > From: Josh Triplett <josh@joshtriplett.org>
> > > > 
> > > > Add support for dividing the refs of a single repository into multiple
> > > > namespaces, each of which can have its own branches, tags, and HEAD.
> > > > Git can expose each namespace as an independent repository to pull from
> > > > and push to, while sharing the object store, and exposing all the refs
> > > > to operations such as git-gc.
> > > [...]
> > > 
> > > By the way, after this feature is merged in, would you like for gitweb
> > > to understand ref namespaces and offer browsing of separate namespaces
> > > (sub-repositories)?
> > 
> > Yes, definitely!  We'd love to see gitweb handling namespaces
> > transparently, and presenting them identically to top-level
> > repositories.  (Also, gitweb would need to present the appropriate
> > repository URIs for cloning.)
> 
> Note that for gitweb support we would need some easy way to list all
> namespaces that given repository provides.  But that is for the future.
> 
> BTW. what do you think about treating repository with own refs and with
> namespaces similarly to how "forks" are handled in gitweb now?

Different namespaces won't necessarily represent forks of the same repository; they may represent entirely separate repositories, with the use of namespaces merely a server-side implementation detail to save space. I'd suggest presenting them as separate repositories.

- Josh Triplett
Previous: Jakub NarebskiNext: Jakub Narebski
Message 10 of 20 in “[PATCHv4 1/4] Refactor for_each_ref variants to use for_each_ref_in and avoid magic numbers”
  1. Jamey SharpJun 1, 2011
  2. 2/4 Add infrastructure for ref namespacesJamey Sharp, Jun 1, 2011
  3. Junio C HamanoJun 2, 2011
  4. Josh TriplettJun 2, 2011
  5. Junio C HamanoJun 3, 2011
  6. Josh TriplettJun 3, 2011
  7. Jakub NarebskiJun 3, 2011
  8. Josh TriplettJun 3, 2011
  9. Jakub NarebskiJun 8, 2011
  10. Josh TriplettJun 9, 2011
  11. Jakub NarebskiJun 9, 2011
  12. 3/4 Support ref namespaces for remote repositories via upload-pack and receive-packJamey Sharp, Jun 1, 2011
  13. Junio C HamanoJun 2, 2011
  14. josh@joshtriplett.orgJun 3, 2011
  15. Junio C HamanoJun 3, 2011
  16. 4/4 Add documentation for ref namespacesJamey Sharp, Jun 1, 2011
  17. Junio C HamanoJun 2, 2011
  18. Josh TriplettJun 2, 2011
  19. Junio C HamanoJun 2, 2011
  20. Jakub NarebskiJun 3, 2011

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.