Re: [PATCH 16/48] i18n: git-pull eval_gettext + warning message
- From
- Bernhard R. Link <brl+ccmadness@pcpool00.mathematik.uni-freiburg.de>
- Date
- May 8, 2011, 16:52 UTC
- Message-ID
- <20110508165254.GA20654@pcpool00.mathematik.uni-freiburg.de>
- In-Reply-To
- <1304857280-14773-17-git-send-email-avarab@gmail.com>
* Ævar Arnfjörð Bjarmason <avarab@gmail.com> [110508 14:23]:
Show 19 quoted lines
> Signed-off-by: Ævar Arnfjörð Bjarmason <avarab@gmail.com> > --- > git-pull.sh | 6 +++--- > 1 files changed, 3 insertions(+), 3 deletions(-) > > diff --git a/git-pull.sh b/git-pull.sh > index 06dcd81..79ba9ab 100755 > --- a/git-pull.sh > +++ b/git-pull.sh > @@ -217,9 +217,9 @@ then > # $orig_head commit, but we are merging into $curr_head. > # First update the working tree to match $curr_head. > > - echo >&2 "Warning: fetch updated the current branch head." > - echo >&2 "Warning: fast-forwarding your working tree from" > - echo >&2 "Warning: commit $orig_head." > + echo >&2 "$(eval_gettext "Warning: fetch updated the current branch head. > +Warning: fast-forwarding your working tree from > +Warning: commit \$orig_head.")"
echo "$(...)"
sounds quite wasteful and harder to read than necessary. The same also happens in later patches.