Re: [PATCH 18/19] Refactor git_remote_cvs to a more generic git_remote_helpers
- From
Johan Herland <johan@herland.net>
- Date
- Oct 30, 2009, 08:42 UTC
- Message-ID
- <200910300942.54101.johan@herland.net>
- In-Reply-To
- <1256839287-19016-19-git-send-email-srabbelier@gmail.com>
On Thursday 29 October 2009, Sverre Rabbelier wrote:
Show 5 quoted lines
> This in an effort to allow future remote helpers written in python to > re-use the non-cvs-specific code. > > Signed-off-by: Sverre Rabbelier <srabbelier@gmail.com> > ---
[snip]
Show 28 quoted lines
> diff --git a/git_remote_helpers/__init__.py > b/git_remote_helpers/__init__.py new file mode 100644 > index 0000000..38c7b5f > --- /dev/null > +++ b/git_remote_helpers/__init__.py > @@ -0,0 +1,27 @@ > +#!/usr/bin/env python > + > +"""Support library package for git remote helpers. > + > +Git remote helpers are helper commands that interfaces with a non-git > +repository to provide automatic import of non-git history into a Git > +repository. > + > +This package provides the support library needed by these helpers.. > +The following modules are included: > + > +- cvs/cvs - Interaction with CVS repositories > + > +- cvs/symbol_cache - Local CVS symbol cache > + > +- cvs/changeset - Collect individual CVS revisions into commits > + > +- cvs/commit_states - Map Git commits to CVS states > + > +- cvs/revision_map - Map CVS revisions to various metainformation > + > +- git/git - Interaction with Git repositories
Since this is Python documentation within a package, I'd rather refer to the python modules as _modules_ and not files. I.e. please use '.' instead of '/':
+- cvs.cvs - Interaction with CVS repositories + +- cvs.symbol_cache - Local CVS symbol cache + +- cvs.changeset - Collect individual CVS revisions into commits + +- cvs.commit_states - Map Git commits to CVS states + +- cvs.revision_map - Map CVS revisions to various metainformation + +- git.git - Interaction with Git repositories
> + > +- util - General utility functionality use by the other modules in > + this package, and also used directly by git-remote-cvs.
Probably you should drop the direct reference to git-remote-cvs.
Show 18 quoted lines
> diff --git a/git_remote_cvs/util.py b/git_remote_helpers/util.py
> similarity index 100%
> rename from git_remote_cvs/util.py
> rename to git_remote_helpers/util.py
> diff --git a/t/test-lib.sh b/t/test-lib.sh
> index 77ad23e..c7530aa 100644
> --- a/t/test-lib.sh
> +++ b/t/test-lib.sh
> @@ -640,9 +640,9 @@ test -d ../templates/blt || {
>
> if test -z "$GIT_TEST_INSTALLED"
> then
> - GITPYTHONLIB="$(pwd)/../git_remote_cvs/build/lib"
> + GITPYTHONLIB="$(pwd)/../git_remote_helpers/build/lib"
> export GITPYTHONLIB
> - test -d ../git_remote_cvs/build || {
> + test -d ../git_remote_helpers/build || {
> error "You haven't built git_remote_cvs yet, have you?"Please also s/git_remote_cvs/git_remote_helpers/ in the error message.
Otherwise, it all looks good :)
...Johan
-- Johan Herland, <johan@herland.net> www.herland.net