git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH JGit 04/19] added utility that generates the contents of the objects/info/packs file as a string from a list of PackFiles

From
Robin Rosenberg <robin.rosenberg.lists@dewire.com>
Date
Sep 15, 2009, 15:35 UTC
Message-ID
<200909151735.58992.robin.rosenberg.lists@dewire.com>
In-Reply-To
<1252867475-858-5-git-send-email-mr.gaffo@gmail.com>
Show 15 quoted lines
> diff --git a/org.spearce.jgit/src/org/spearce/jgit/lib/PacksFileContentsCreator.java b/org.spearce.jgit/src/org/spearce/jgit/lib/PacksFileContentsCreator.java
> new file mode 100644
> index 0000000..3dd0418
> --- /dev/null
> +++ b/org.spearce.jgit/src/org/spearce/jgit/lib/PacksFileContentsCreator.java
> @@ -0,0 +1,21 @@
> +package org.spearce.jgit.lib;
> +
> +import java.util.List;
> +
> +public class PacksFileContentsCreator {
> +
> +	private List<PackFile> packs;
> +
> +	public PacksFileContentsCreator(List<PackFile> packs) {

We want good javadocs for (at least) all public and protected methods and classes. (We enforce this for Eclipse users). If we had similar configuration files for, perhaps netbeans we might have those too. (not finished thinking about that proposition...)

> +		this.packs = packs;
> +	}
> +	
> +	public String toString(){

Don't overload toString. Let it be useful for debug like purposes. With this style we cannot make it useful since the application depends on its exact behaviour. You may define a toString anyway that does the exact same thing, but please provide a specific method for assisting with the formatting of the file. A writeTo(OutputStream) is a useful interface in general.

> +		StringBuilder builder = new StringBuilder();
> +		for (PackFile packFile : packs) {
> +			builder.append("P ").append(packFile.getPackFile().getName()).append('\r');

At least my git formats the file with \n as line terminator, so I think JGit should too.. Git ends the file with an extra \n, though I'm not sure it's relevant.

> +		}
> +		return builder.toString();
> +	}

The name is somewhat confusing as the s is hard to spot. The suggestion InfoPacksFileGenerator perhaps. It's a bit uglier by easier not to mix with generation of pack files.

-- robin
Previous: Robin RosenbergNext: Robin Rosenberg
Message 24 of 25 in “Adding update-server-info functionality”
  1. Adding update-server-info functionalitymr.gaffo@gmail.com, Sep 13, 2009
  2. 01/19 adding tests for ObjectDirectorymr.gaffo@gmail.com, Sep 13, 2009
  3. 02/19 Create abstract method on ObjectDatabase for accessing the list of local pack files.mr.gaffo@gmail.com, Sep 13, 2009
  4. 03/19 Add abstract method for updating the object db's info cache Implemented passthrough on Alternate for the update of infocachemr.gaffo@gmail.com, Sep 13, 2009
  5. 04/19 added utility that generates the contents of the objects/info/packs file as a string from a list of PackFilesmr.gaffo@gmail.com, Sep 13, 2009
  6. 05/19 Made tests for listLocalPacks function on ObjectDirectory and made them passmr.gaffo@gmail.com, Sep 13, 2009
  7. 06/19 added utility for reading the contents of a file as a stringmr.gaffo@gmail.com, Sep 13, 2009
  8. 07/19 implemented the packs file update functionalitymr.gaffo@gmail.com, Sep 13, 2009
  9. 08/19 changed signature to allow a IOExceptionmr.gaffo@gmail.com, Sep 13, 2009
  10. 09/19 Didn't like the old name, this is more specific to it just updating the packs info cachemr.gaffo@gmail.com, Sep 13, 2009
  11. 10/19 moved test up to a higher level to test actual functionalitymr.gaffo@gmail.com, Sep 13, 2009
  12. 11/19 removed unused importmr.gaffo@gmail.com, Sep 13, 2009
  13. 12/19 moved info/packs into a constantmr.gaffo@gmail.com, Sep 13, 2009
  14. 13/19 made the call update the object database's info cachemr.gaffo@gmail.com, Sep 13, 2009
  15. 14/19 pulled out some helper functions that will be useful for other testsmr.gaffo@gmail.com, Sep 13, 2009
  16. 15/19 Adding in a InfoDatabase like ObjectDatabase and and implementation based upon a directory.mr.gaffo@gmail.com, Sep 13, 2009
  17. 16/19 added tests for the file based info cache update and made passmr.gaffo@gmail.com, Sep 13, 2009
  18. 17/19 added call to update the info refs filemr.gaffo@gmail.com, Sep 13, 2009
  19. 18/19 Added Copyright Noticesmr.gaffo@gmail.com, Sep 13, 2009
  20. 19/19 changed \r to \n per compliance with real gitmr.gaffo@gmail.com, Sep 13, 2009
  21. Robin RosenbergSep 15, 2009
  22. Robin RosenbergSep 15, 2009
  23. Robin RosenbergSep 15, 2009
  24. Robin RosenbergSep 15, 2009
  25. Robin RosenbergSep 15, 2009

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.