On Fri, Jan 02, 2009 at 10:59:47PM +0100, Johannes Schindelin wrote:
Show 26 quoted lines
> This explanation makes sense. However, this:
>
> > @@ -289,7 +289,8 @@ static int unpack_nondirectories(int n, unsigned long mask, unsigned long dirmas
> > return 0;
> > }
> >
> > -static int unpack_callback(int n, unsigned long mask, unsigned long dirmask, struct name_entry *names, struct traverse_info *info)
> > +static int unpack_callback(int n, unsigned long mask, unsigned long dirmask,
> > + struct name_entry *names, struct traverse_info *info)
> > {
> > struct cache_entry *src[5] = { NULL, };
> > struct unpack_trees_options *o = info->data;
>
> ... is distracting during review, and this:
>
> > @@ -517,22 +518,22 @@ static int verify_clean_subdirectory(struct cache_entry *ce, const char *action,
> > namelen = strlen(ce->name);
> > pos = index_name_pos(o->src_index, ce->name, namelen);
> > if (0 <= pos)
> > - return cnt; /* we have it as nondirectory */
> > + return 0; /* we have it as nondirectory */
> > pos = -pos - 1;
> > for (i = pos; i < o->src_index->cache_nr; i++) {
>
> ... is not accounted for in the commit message. Intended or not, that is
> the question.Those are trivial readability improvements in the context of the patch.
On Fri, Jan 02, 2009 at 10:59:43PM +0100, Johannes Schindelin wrote: