Re: [PATCHv5 2/3] gitweb: add patches view
- From
Jakub Narebski <jnareb@gmail.com>
- Date
- Dec 18, 2008, 17:28 UTC
- Message-ID
- <200812181828.11815.jnareb@gmail.com>
- In-Reply-To
- <cb7bb73a0812180823y5249abcakd419d4fee9942d84@mail.gmail.com>
On Thu, Dec 18, 2008, Giuseppe Bilotta wrote:
> On Thu, Dec 18, 2008, Jakub Narebski <jnareb@gmail.com> wrote: >> On Thu, 18 Dec 2008, Junio C Hamano wrote:
Show 14 quoted lines
>>> [...] wouldn't it make more sense to also do this? >>> >>> git_commitdiff(--format => 'patch', --single => 1); >>> git_commitdiff(--format => 'html'); >> >> The first argument (format) is _required_, second is _optional_; >> I'd rather use named parameters trick only for optional parameters. >> Because with more than one optional parameter function call begins >> to be cryptic; also flag (boolean) parameters are more readable >> when used as named parameters. > > I have mixed feelings about this: on the one hand we have href() (say) > that takes all its params from a has, but on the other hand we have > esc_html() (say) that takes only additional options from a hash. [...]
It is not "on one hand". href() is a bit special case. It has _all_ parameters optional, especially now that -replay=>1 was introduced. It has no required parameters. Therefore all parameters are named.
Beside, href() mimics a bit CGI interface...
-- Jakub Narebski Poland