Re: [PATCH 4/4] cygwin: Use native Win32 API for stat
- From
Dmitry Potapov <dpotapov@gmail.com>
- Date
- Sep 29, 2008, 18:26 UTC
- Message-ID
- <20080929182600.GI21650@dpotapov.dyndns.org>
- In-Reply-To
- <20080929153400.GJ17584@spearce.org>
On Mon, Sep 29, 2008 at 08:34:00AM -0700, Shawn O. Pearce wrote:
Show 8 quoted lines
> Johannes Sixt <johannes.sixt@telecom.at> wrote: > > > My point is that emphasis on "stat" in the name is wrong: That's about > > implementation, but not about the effect. Why wouldn't 'ignoreCygwinFSTricks' > > be specific enough? > > I like this a lot better. I could see us also bypassing other Cygwin > functions like open() in order to get faster system calls for Git.
If you think that it may be useful to bypass some other functions, and you want to use the same option to control that then a general name like that makes sense. Personally, I don't believe that we may want to bypass something like open() as it is not performance critical, but I said above I don't care about the name much, so I am going to change my patch to use ignoreCygwinFSTricks.
Dmitry