Re: [PATCH 4/4] cygwin: Use native Win32 API for stat
- From
Johannes Sixt <johannes.sixt@telecom.at>
- Date
- Sep 28, 2008, 09:24 UTC
- Message-ID
- <200809281124.08364.johannes.sixt@telecom.at>
- In-Reply-To
- <20080927215406.GG21650@dpotapov.dyndns.org>
On Samstag, 27. September 2008, Dmitry Potapov wrote:
> On Sat, Sep 27, 2008 at 08:35:03PM +0200, Johannes Sixt wrote: > > > +core.cygwinNativeStat:: > > > > This name is *really* odd, for two reasons:
...
> It was Shawn's suggestion. I don't care much about the name as long as > it is explained in the documentation... Therefore, I accepted what Shawn > said without giving it any thought.
Shawn is an importen git-o-maniac, but it's certainly not blasphemy to question his words of wisdom ;)
Show 6 quoted lines
> Now, when you bring this name to my > attention, I believe core.useCygwinStat (in the opposite to the current > core.cygwinNativeStat) would be a better name. Your name is okay too, > but a bit too long for my taste and not specific enough (I suppose > Cygwin does many FS related tricks). Anyway, I don't have a strong > opinion here, so just whatever most people like is fine with me :)
My point is that emphasis on "stat" in the name is wrong: That's about implementation, but not about the effect. Why wouldn't 'ignoreCygwinFSTricks' be specific enough? By using a native stat implementation, *all* of them are ignored. Yes, you fall back to Cygwin's stat sometimes, but these are cases where the *effect* is not that relevant. (And the length of the name doesn't worry me, considering how many people would want to change the default.)
-- Hannes