Re: [PATCH] gitweb: use Git.pm, and use its parse_rev method for git_get_head_hash
On Sat, May 31, 2008 at 01:00:12AM +0200, Lea Wiemann wrote:
Show 10 quoted lines
> This simplifies git_get_head_hash a lot; the method might eventually
> even go away.
>
> I haven't checked whether this causes an IO performance regression by
> instantiating a new Git repository instance, but in the end
> Git->repository will be as fast as possible and do no eager disk
> accesses. No benchmarking yet at this stage.
>
> Minor change: Moved the parameter shift in git_blob_plain to the top
> for readability.
Please split this to a separate patch.
> Signed-off-by: Lea Wiemann <LeWiemann@gmail.com>
Other than that,
Acked-by: Petr Baudis <pasky@suse.cz>
--
Petr "Pasky" Baudis
Whatever you can do, or dream you can, begin it.
Boldness has genius, power, and magic in it. -- J. W. von Goethe