From: Petr Baudis Date: Sat, 31 May 2008 13:04:51 GMT Subject: Re: [PATCH] gitweb: use Git.pm, and use its parse_rev method for git_get_head_hash Message-ID: <20080531130450.GI18781@machine.or.cz> In-Reply-To: <1212188412-20479-1-git-send-email-LeWiemann@gmail.com> On Sat, May 31, 2008 at 01:00:12AM +0200, Lea Wiemann wrote: > This simplifies git_get_head_hash a lot; the method might eventually > even go away. > > I haven't checked whether this causes an IO performance regression by > instantiating a new Git repository instance, but in the end > Git->repository will be as fast as possible and do no eager disk > accesses. No benchmarking yet at this stage. > > Minor change: Moved the parameter shift in git_blob_plain to the top > for readability. Please split this to a separate patch. > Signed-off-by: Lea Wiemann Other than that, Acked-by: Petr Baudis -- Petr "Pasky" Baudis Whatever you can do, or dream you can, begin it. Boldness has genius, power, and magic in it. -- J. W. von Goethe