Re: [PATCH 3/3] send-pack: assign remote errors to each ref
- From
Jeff King <peff@peff.net>
- Date
- Nov 18, 2007, 00:03 UTC
- Message-ID
- <20071118000306.GA4000@sigill.intra.peff.net>
- In-Reply-To
- <Pine.LNX.4.64.0711171258000.12193@iabervon.org>
On Sat, Nov 17, 2007 at 01:05:29PM -0500, Daniel Barkalow wrote:
> Maybe this should take both the full list and the hint and do both passes > internally? IMHO, the logic in receive_status() looks like it might be > setting the error twice or not at all, unless you read very carefully.
Not unreasonable, though I started in that direction and it ended up being less readable (which isn't to say that it's not possible). But it looks like Junio has merged to next, so I think it is best to leave it as-is.
-Peff