git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 1/7] "git" calls help_unknown_cmd(""); "git help" and "git help -a" return 0

From
Scott Parish <srp@srparish.net>
Date
Oct 27, 2007, 07:16 UTC
Message-ID
<20071027071631.GA16359@srparish.net>
In-Reply-To
<7v640twka3.fsf@gitster.siamese.dyndns.org>
On Fri, Oct 26, 2007 at 04:03:48PM -0700, Junio C Hamano wrote:
Show 11 quoted lines
> > Regarding "git: '' is not a git-command" the way i was seeing that
> > is that git is usually only called with commands, and '' isn't a
> > valid command, hence the reason to exit 1, the help is just a nice
> > user experience.
> 
> But think who would type "git<Enter>".  They are either people
> who (1) do not even know that "git" alone is not useful and that
> it always wants a subcommand, or (2) know "git<Enter>" is the
> same as "git help" and wants to get the "common command list"
> quickly.  Technically, "'' is not a git-command" is correct, but
> the message does not help either audience, does it?

Fair enough, i'll drop that in the updated patch set i'm about ready to send. Incidentally i was also missing the "usage" string.

sRp
-- 
Scott Parish
http://srparish.net/
Previous: Junio C Hamano
Message 19 of 19 in “"git" calls help_unknown_cmd(""); "git help" and "git help -a" return 0”
  1. 1/7 "git" calls help_unknown_cmd(""); "git help" and "git help -a" return 0Scott R Parish, Oct 25, 2007
  2. 2/7 s/pattern/prefix/ in help's list_commandsScott R Parish, Oct 25, 2007
  3. 3/7 "current_exec_path" is a misleading name, use "argv_exec_path" Signed-off-by: Scott R Parish <srp@srparish.net>Scott R Parish, Oct 25, 2007
  4. 4/7 use only the PATH for exec'ing git commandsScott R Parish, Oct 25, 2007
  5. 5/7 chdir() into list_commands() dir instead of building paths for stat()Scott R Parish, Oct 25, 2007
  6. 6/7 walk PATH to generate list of commands for "help -a"Scott R Parish, Oct 25, 2007
  7. 7/7 shell should call setup_path() instead of manually setting up its pathScott R Parish, Oct 25, 2007
  8. Junio C HamanoOct 25, 2007
  9. Scott ParishOct 25, 2007
  10. Junio C HamanoOct 25, 2007
  11. Scott ParishOct 25, 2007
  12. Junio C HamanoOct 25, 2007
  13. Scott ParishOct 25, 2007
  14. 2/7 remove unused/unneeded "pattern" argument of list_commandsScott R Parish, Oct 25, 2007
  15. 5/7 chdir() into list_commands() dir instead of building paths for stat()Scott R Parish, Oct 25, 2007
  16. Junio C HamanoOct 25, 2007
  17. Scott ParishOct 25, 2007
  18. Junio C HamanoOct 26, 2007
  19. Scott ParishOct 27, 2007

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.