Re: [PATCH 2/7] s/pattern/prefix/ in help's list_commands
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Oct 25, 2007, 04:41 UTC
- Message-ID
- <7v640v3ix1.fsf@gitster.siamese.dyndns.org>
- In-Reply-To
- <1193283437-1706-2-git-send-email-srp@srparish.net>
Scott R Parish <srp@srparish.net> writes:
> list_commands() currently accepts and ignores a "pattern" argument, > and then hard codes a prefix as well as some magic numbers.
Correct observation.
Personally, I find this static function should not pretend to be as flexible --- it is to list git subcommands anyway (and it even knows about ".exe"), so rather than renaming the pattern and using it, it might be simpler and cleaner to just drop the parameter and be done with it.